Photo Upload Error "Cannot create directory"

The ios app could not upload fresh photos and presents the error “Cannot create directory or file” (or similar, did not write down the exact message). I have activated “Verwende Unterordner” (“use subfolder”).

Maybe, it is because I moved the folders from the upload dir to another location, and so the subfolders for ervery year/month are not existing anymore on the server. After I created the folder “2017/05” inside the photos folder manually, the upload works again.

Hi @dartcafe

have you moved the folders via cli / winscp or via WebClient?

Pls, check the permission of your /data folder and set it to e.g. www-data

sudo chown -R www-data:www-data /var/www/nextcloud/data

rescan the files

sudo -u www-data php /var/www/nextcloud/occ files:scan --all

I moved the folder local on my PC, which was then synchronized via the windows client. file permissions are fine.

Idea: Clear cache on your iOS device and try again.

I will mark this as solved, cause I tried to reproduce this issue, but I could not.