Pfsense haproxy and error nextcloud

Hello everyone, I use nextcloud and in the summary information the following inscription appears:

The reverse proxy header configuration is incorrect

I think this is an error regarding HTTP “X-Forwarded-For” . I’ve tried different configurations by reading a little on the forums, but nothing to do.

Has anyone solved it?

Based on the limited information you provided on your environment, I bet it’s the obvious first usual suspect to look into: check your Nextcloud’s config.php file and check if you have correct entry for ‘trusted_proxies’ => parameter.

Hi leo, I’ve tried all the syntaxes, but it keeps giving an error. If you know how to do it, could you give me a valid example? My proxy-ha has an ip 192.168.3.2

Thank you

'trusted_proxies' => 'http://your proxy ip address:your proxy port',

Hi Leo , I wanted to tell you that after several attempts to configure on the truste_proxies , I finally managed to delete the warning related to the header of the proxy headers . The change consists of adding the proxy name fqdn to the array. e.g. ‘myproxy.fdqn’ . It doesn’t report anything on my server anymore.

1 Like