Per Webdav können keine Dateien größer 65 MBit kopiert werden

Hallo,

ich habe das oben genannte Problem bei Nextcloud 16.04 und 16.05:

Fehlercode Nextcloud gibt folgendes aus:

Blockquote

[webdav] Fatal: Sabre\DAV\Exception\BadRequest: expected filesize 72133282 got 66543616 at <>

  1. /share/MD0_DATA/Web/nextcloud/apps/dav/lib/Connector/Sabre/Directory.php line 156
    OCA\DAV\Connector\Sabre\File->put(null)
  2. /share/MD0_DATA/Web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 1096
    OCA\DAV\Connector\Sabre\Directory->createFile(“VID_20151231_234442.mp4”, null)
  3. /share/MD0_DATA/Web/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 525
    Sabre\DAV\Server->createFile(“VID_20151231_234442.mp4”, null, null)
  4. <>
    Sabre\DAV\CorePlugin->httpPut(Sabre\HTTP\Reque … "}, Sabre\HTTP\Response {})
  5. /share/MD0_DATA/Web/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    undefinedundefinedcall_user_func_array([Sabre\DAV\CorePlugin {},“httpPut”], [Sabre\HTTP\Requ … }])
  6. /share/MD0_DATA/Web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 479
    Sabre\Event\EventEmitter->emit(“method:PUT”, [Sabre\HTTP\Requ … }])
  7. /share/MD0_DATA/Web/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 254
    Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Reque … "}, Sabre\HTTP\Response {})
  8. /share/MD0_DATA/Web/nextcloud/apps/dav/appinfo/v1/webdav.php line 80
    Sabre\DAV\Server->exec()
  9. /share/MD0_DATA/Web/nextcloud/remote.php line 163
    undefinedundefinedrequire_once("/share/MD0_DATA … p")

PUT /nextcloud/remote.php/webdav/VID_20151231_234442.mp4
from 192.168.x.xx by Milchmann at 2019-10-07T14:23:25+00:00

In die .htaccess habe ich die folgenden Zeilen eingefügt:

Blockquote

php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value mbstring.func_overload 0
php_value default_charset ‘UTF-8’
php_value output_buffering 0

SetEnv htaccessWorking true

Kann jemand zu diesem Thema etwas sagen?
Leider bin ich hier nicht so firm und hoffe auf Hilfe .

Danke

Bert

Hallo
was sagt die php.ini ?

Was meinst du. Brauchst du den Inhalt der php.Ini? Ich habe nicht viel Ahnung von Nextcloud und Linux.

Danke

^^
OK was steht bei dir als admin in den Einstellungen unter “Übersicht” (fehler da ?) und unter “Information”
bei php ?

bitte ^^

Da steht:

Es gibt einige Warnungen bei Deiner Systemkonfiguration.

  • MySQL wird als Datenbank verwendet, unterstützt jedoch keine 4-Byte-Zeichen. Um beispielsweise 4-Byte-Zeichen (wie Emojis) ohne Probleme mit Dateinamen oder Kommentaren verarbeiten zu können, wird empfohlen, die 4-Byte-Unterstützung in MySQL zu aktivieren. Für weitere Details lesen bitte.

  • Der „X-Frame-Options“-HTTP-Header ist nicht so konfiguriert, dass er „SAMEORIGIN“ entspricht. Dies ist ein potentielles Sicherheitsrisiko und es wird empfohlen, diese Einstellung zu ändern.

  • Der “Strict-Transport-Security” HTTP-Header ist nicht auf mindestens “15552000” Sekunden eingestellt. Für mehr Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in den Sicherheitshinweisen erläutert ist.

  • Dein Web-Server ist nicht richtig eingerichtet um “well-known/caldav” aufzulösen. Weitere Informationen findest Du in der

  • Dein Web-Server ist nicht richtig eingerichtet um “well-known/carddav” aufzulösen. Weitere Informationen findest Du in der

  • Es wurde kein PHP-Memory-Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest Du in der

  • Das PHP-OPcache-Modul ist nicht geladen. das Modul in Deiner PHP-Installation zu laden.

Geht aber nicht anders , da Nextcloud auf einem QNAP läuft.

Bert

leute ^^ das steht nicht ohne grund unter “Sicherheits- und Einrichtungswarnungen”

Ok du hast apache2 ? ^^

ja

Apache 2.0 Handler Ian Holsman, Justin Erenkrantz (based on Apache 2.0 Filter code)

https://docs.nextcloud.com/server/13/admin_manual/configuration_server/caching_configuration.html

das ist in der config.php einzustellen

das musst du in apache in der conf einbinden

ca so

<Directory /var/www/html/>
Options MultiViews FollowSymLinks
AllowOverride All

  <IfModule mod_dav.c>
    Dav off
  </IfModule>

   SetEnv HOME /var/www
   SetEnv HTTP_HOME /var/www
 </Directory>

 <IfModule mod_headers.c>
      Header always set Strict-Transport-Security "max-age=15768000; preload"
 </IfModule>

und der fehler ist in der datenbank

sudo mysql -u root “ENTER”
ALTER DATABASE cloud CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci; “ENTER”
EXIT; “ENTER”

ich hoffe deine cloud ligt in www/nextcloud und heist nextcloud ansonsten anpassen :wink:

sudo -u www-data php /var/www/nextcloud/occ config:system:set mysql.utf8mb4 --type boolean --value=“true”

“ENTER” das selbe noch mal anpassen und senden in der console

sudo -u www-data php /var/www/nextcloud/occ maintenance:repair “ENTER”

sollte damit gehen

den fehler

solltest du so beheben können

schreib es einfach oben bei dazu :wink:

Danke, aber…

Die Fehler kann ich nicht beheben, weil QNAP Verzeichnisse Schreibfest gemacht hat. Bei jedem Neustart werden die Daten überschrieben.

Die Fehler habe ich schon seitdem ich nextcloud auf das QNAP gespielt habe ( 3 Jahre)
Aber was hat das mit dem Fehler zu tun in Beitrag 1 , dass ich keine Dateien grösser 64 MBit kopieren kann?

Die letzten 2 Punkte versuche ich, dafür danke .

Bert

hmm… das solltest du aber änder können
hast du keine root rechte drauf ?

Doch, QNAP hat das Bootfest gemacht, es gibt Umgehungslösungen, aber diese ändern sich auch immer wieder.

Hast du noch eine Idee wegen dem Kopieren der Dateien?

jo einige wenn ich wüste welche soft und menchanissmen der hat ^^ ich nehme an das was da google ausspuckt

das teil hat die cloud als app/createVM oder so geladen oder? ^^

Als App, und dann habe ich php auf die Version 7.2. angehoben nach der folgenden Anleitung:

https://forum.qnapclub.de/thread/52321-anleitung-nextcloud-upgrade-mit-mysql-db-ohne-docker-qapache/?pageNo=1

also wenn es geht würde ich einen einfachen weg gehen der auch zukunft hat ^^

das bedeutet in deinem fall Ubuntu 18.04 install wenn das geht und die nextcloud selber installen ist einfacher und stabiler brauchst auch keinen desktop dafür server version geht immer ohne ^^

Ja, bedeutet aber ein neues NAS. Deswegen bin ich aber mein Problem aus dem Anfangspost noch nicht los. Jemand andere Ideen?

Ok versuchen wir es mal so ^^
geht die app ?
https://apps.nextcloud.com/apps/occweb
Jetzt weis ich net viel über die app

aber versuche mal den

config:system:set mysql.utf8mb4 --type boolean --value=“true”
maintenance:repair

Sollte es gehen können wir einen weiteren einfachen weg gehen ich hoffe der speichert das dann auch :wink:

@NextGeneration

Installation hat geklappt. Umstellung auf 5 Byte auch, aber jetzt kommen Fehler nach

maintenance:repair

Kannst du weiter helfen? Nextcloud ist jetzt auch im Wartungsmodus!

Blockquote

occ $ config:system:set mysql.utf8mb4 --type boolean --value=“true”
System config value mysql.utf8mb4 set to boolean true
occ $ maintenance:repair

  • Repair MySQL collation
    • Change row format for oc_accounts …
    • Change collation for oc_accounts …
    • Change row format for oc_activity …
    • Change collation for oc_activity …
    • Change row format for oc_activity_mq …
    • Change collation for oc_activity_mq …
    • Change row format for oc_addressbookchanges …
    • Change collation for oc_addressbookchanges …
    • Change row format for oc_addressbooks …
    • Change collation for oc_addressbooks …
      In AbstractMySQLDriver.php line 125:

An exception occurred while executing ‘ALTER TABLE oc_addressbooks CONVER
T TO CHARACTER SET utf8mb4 COLLATE utf8mb4_bin;’:

SQLSTATE[42000: Syntax error or access violation: 1071 Specified key was t ]
oo long; max key length is 767 bytes

In PDOStatement.php line 143:

SQLSTATE[42000: Syntax error or access violation: 1071 Specified key was t ]
oo long; max key length is 767 bytes

In PDOStatement.php line 141:

SQLSTATE[42000: Syntax error or access violation: 1071 Specified key was t ]
oo long; max key length is 767 bytes

maintenance:repair [–include-expensive]
occ $ maintenance:repair --include-expensive
[object Object]
occ $ maintenance:repair

Zwei dinge Was steht jetzt in “Sicherheits- und Einrichtungswarnungen” ?

der Punkt sollte sich geändert haben

Und kannst du phpmyadmin laden ?

drei dinge ^^ konnte wenn alles pass er es auch speichern ? :grin:

@NextGeneration
2. Punkt ja

  1. Punkt : Ja ist weg dafür jetzt:
    Einige Dateien haben die Integritätsprüfung nicht bestanden. Weiterführende Informationen befinden sich in unserer

Technical Information:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • .htaccess

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.htaccess] => Array
(
[expected] => f30494d88fc2d7caf0be8b27629cb246483cea0203696e44fd376bff19db51bb89c9f4076b1f849627ef3cb011f4a20088116e7b0d10ce467a3dde5db71e108b
[current] => e50bc7d79cb2e646f0979af5b29f20c57ecd84bc1ff7398b417631313ebffb68b3ca252366e6f0c0ded2d72692aaf59b4ddbf98fc9c2c17c54553ad2c308a4b0
)

            )

    )

)

Habe den Maintenance Modus über die php.ini ausgeschaltet

hmm das klingt ja schon mal nicht schlecht Ich vermute jetzt mal ins blaue
Du hast nicht wirklich root auf dem system sonder das nas hat mehr recht als du
Zwei dinge schau nach welche rechte die dateien haben ändere sie ab auf deine ändere dann den inhalt der datei und vergib wieder die alten rechte dann sollte es in zukunft so gehen

oder Variante 2
du musst eine php hochladen wo die die dateie abändern kannst aber die rechte vom system hat

naja das kommt davon weil du die datei bearbeitet hast wenn nicht lade die richtige von nextcloud runter und ersetze diese dann damit

achte aber darauf das der inhalt stimmt der neuen datei