PDF-Preview not showing in Nextcloud Explorer folder

So basically our customer uses our Nextcloud service and wants to use the preview function of the Windows Explorer and Adobe reader to quickly find PDF-Files without the need to open them.
Unfortunately exactly this is not working in the Eplorer folder from Nextcloud. If you take any PDF-File in there and paste it to the local computer, it will show as intended. Even if you paste it to a net-share.
I am not sure if this is a problem caused by Nextcloud settings or by the Windows PC itself.

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.0.4
Operating system and version (eg, Ubuntu 20.04): CentOS Linux 7
Apache or nginx version (eg, Apache 2.4.25): Linux 3.10.0-1160.76.1.el7.x86_64
PHP version (eg, 7.4): PHP 7.0.33

The issue you are facing:
PDF-Files cannot be seen via PDF-Preview Handler in Windows Explorer. Files are shown as PDF-Images instead of showing the first page of the PDF-File.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Installing Nextcloud on the client and setting up a sync to the webserver

Setting Adobe Reader DC to the main PDF-Program and also enabling PDF-Preview in Explorer in the Adobe Reader Settings.

Enabling Always show icons, never thumbnails in Explorer options. Now every PDF-File should be showing its first page instead of the PDF-Icon.
It works everywhere but in the Nextcloud folder.

Are they using “Virtual Files”? If so it cannot work, because the file isn’t actually there. With Virtual Files the previews can only be rendered for files that have been been marked as “always available offline” or files that already have been opened / double-clicked once, i.e. the files have to be downloaded / stored locally, in order for Windows Explorer to be able to render the preview.

All the files are marked as “always aviable offline”, thats why I am wondering why its not working properly, since the files should be treated as if they were locally

Sorry then I don’t know why it doesn’t work. I tested it briefly in a Windows 10 VM, and the preview worked for me, after I have set a PDF file to “always available offline”.