PDF files wont open

Suddenly, when clicking PDF files on the WEB interface, they won’t open. It hangs forever in Opening file.
However, when clicking on the 3 dots to the right of the filename, and select View it works immediately.
For all other file types it works fine.
Any ideas?

  • Server version?
  • Apps installed? (PDFs are handled by several potential apps)
  • Any messages in your browser console when it hangs?

Server version: latest NextCloud 2.8.3 on Hetzner Storage Share.
OnlyOffice v 9.1.2. (community server)
No other messages but blank section on page with “Loading file…”
Only for PDF files.
BR Johnny

Solved the problem by disabling the handling of PDF files in the OnlyOffice configuration.

Could this be because OnlyOffice does not support editing PDF files??

BR Johnny


there is PDF for reading and filling mentioned as supported file format.
Is it possible, that you tried to open the PDF for editing?

We are using the community server, and in the configurations settings we had set it to be standard for PDF files. If I remove this, it works. I guess, in the case it’s set, OnlyOffice is trying to open for editing.

If I, at the file viewer, select Edit file with OnlyOffice, it hangs as before.

I don’t see any options for only reading or filling.

BR Johnny