PDF converter workflow not working

Nextcloud version (eg, 18.0.2): 18.0.5
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04.4
Apache or nginx version (eg, Apache 2.4.25): nginx 1.14.0
PHP version (eg, 7.1): PHP 7.4.6

The issue you are facing:

Set up a PDF conversion flow as follows:
When File created, File updated
and File MIME type matches Office documents
=> Keep original, overwrite existing PDF

You’d expect that when creating a new odt file with Collabora Online Development Edition, or just uploading a new odt file, you would see its corresponding pdf appearing aside, but nothing happens.

And absolutely nothing in the nextcloug log (loglevel : 2).

Yet, libreoffice --headless --invisible --norestore --convert-to pdf file.odt works fine in a terminal.

An issue’s been opened on github 19 days ago, and so far, still not taken into account.

Looks like this feature’s not working (at all?)…

I’ve always thought I didn’t know how to make it work, but obviously I’m not alone not being able to convert to pdf. For months it has never worked for me as well.