Passwords fails to decode "authenticated ciphertext"

Hello, after updating to 2018.9.0 I cannot load the passwords and get the following error in the DB:

Exception: Authenticated ciphertext could not be decoded.

/var/www/nextcloud/apps/passwords/lib/Encryption/SseV1Encryption.php - line 136: OC\Security\Crypto->decrypt(*** sensitive parameters replaced ***)
/var/www/nextcloud/apps/passwords/lib/Services/EncryptionService.php - line 89: OCA\Passwords\Encryption\SseV1Encryption->decryptObject(Object(OCA\Passwords\Db\PasswordRevision))
/var/www/nextcloud/apps/passwords/lib/Helper/ApiObjects/AbstractObjectHelper.php - line 111: OCA\Passwords\Services\EncryptionService->decrypt(*** sensitive parameters replaced ***)
/var/www/nextcloud/apps/passwords/lib/Helper/ApiObjects/PasswordObjectHelper.php - line 104: OCA\Passwords\Helper\ApiObjects\AbstractObjectHelper->getRevision(Object(OCA\Passwords\Db\Password), Array)
/var/www/nextcloud/apps/passwords/lib/Controller/Api/AbstractObjectApiController.php - line 91: OCA\Passwords\Helper\ApiObjects\PasswordObjectHelper->getApiObject(Object(OCA\Passwords\Db\Password), 'model', Array)
[internal function] OCA\Passwords\Controller\Api\AbstractObjectApiController->list('model')
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 161: call_user_func_array(Array, Array)
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 91: OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Passwords\Controller\Api\PasswordApiController), 'list')
/var/www/nextcloud/lib/private/AppFramework/App.php - line 115: OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Passwords\Controller\Api\PasswordApiController), 'list')
/var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47: OC\AppFramework\App main('PasswordApiCont...', 'list', Object(OC\AppFramework\DependencyInjection\DIContainer), Array)
[internal function] OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)
/var/www/nextcloud/lib/private/Route/Router.php - line 297: call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)
/var/www/nextcloud/lib/base.php - line 999: OC\Route\Router->match('/apps/passwords...')
/var/www/nextcloud/index.php - line 42: OC handleRequest()

What happened? What means “Authenticated ciphertext”? Would it work to load the previous release?

I’m having a similar error. Just updated today and the passwords app doesn’t load in my browser. I can read it from my anroid app though. I just get a spinning icon on the passwords app tab.

Yeah same with me at desktop but i don’t know which Android app do you mean. I didn’t open an Git-issue because there is “no support” but if the dev doesn’t care here i’ll open one. If he made a mistake or whatever happened it’s ok but i am waiting 3 days for getting back my passwds and my last backup is from one month before…
If i would know that’s “just” a decoding problem i would ask you all how i can load the previous version of the app but maybe trough the update keys were lost or the DB was corrupted.

I was able to revert to a previous backup of my database and host files. I’m just not going to update it again. Apparently there are three separate checks it does to validate the user. If any of those keys get damaged it’s unrecoverable.

Hello and sorry i did not answer. I was not notified of this topic until today.

There is already an issue over on github which sounds quite similar. Maybe you can leave a comment there and add some information on your Nextcloud setup.
Did you upgrade to Nextcloud 14?
Which Database do you use?
Do you use something like LDAP?
Does the browser extension or the android app work?

To have all in one Thread i’ll post it later on the github-issue you’ve linked :slight_smile:

Edit 20:28: done

1 Like

After collecting many information we found the bug and finally solved it. A new version of passwords will be released shortly.
The Bug and how it’s solved is described here: