Passwords broken on NC 13.0.5 RC1?

Hi i been using Passwords for a few months and been quite happy with it, it covers my usecase perfectly.

However I run my NC on beta update channel and recently upgraded to 13.0.5 RC 1. Since then the passwords app (2018.7.0) have been disabled and there is no way to reenable it.

I have this in my log from the time of update.

TypeError: Return value of OCA\Passwords\AppInfo\Application::registerController() must be an instance of OCA\Passwords\AppInfo\void, none returned
/apps/passwords/lib/AppInfo/Application.php - line 72: OCA\Passwords\AppInfo\Application->registerController()
/apps/passwords/lib/AppInfo/Application.php - line 56: OCA\Passwords\AppInfo\Application->registerDiClasses()
/apps/passwords/appinfo/app.php - line 8: OCA\Passwords\AppInfo\Application->__construct()
/lib/private/legacy/app.php - line 245: require_once(’/home/…’)
/lib/private/legacy/app.php - line 154: OC_App requireAppFile(‘passwords’)
/lib/private/legacy/app.php - line 127: OC_App loadApp(‘passwords’)
/lib/base.php - line 996: OC_App loadApps()
/index.php - line 42: OC handleRequest()
{main}

Is this a known problem? and is there an easy fix for it. Also I’m not sure if the forum is the right place for this type of question, would it be better to open an issue on Gitlab?

Regards,
Daniel

This error seems to be caused by a function that has the return type void.
Your webserver is probably using PHP 7.0 or earlier where void return types cause this error.
The passwords app requires PHP 7.1.

1 Like

Hi @mdw thanks for the quick reply… I’m running on an shared webhost and actually had checked and enabled 7.1 for the subdomain in cpanel. Changed it to 7.2 and that solved the problem :slight_smile:

1 Like

It is somewhat strange. I checked with the official docker image (nextcloud:rc-fpm) which is running PHP 7.1.19 and everything works fine. Maybe the configuration got messed up somehow? You can check the PHP version in the Nextcloud Admin Settings in the Information section.

I honestly think it works fine on 7.1, my host have recently updated their servers, so I think some of the settings have not been properly reenabled. The native setting in cpanel was 7.0 and i only checked the cpanel configuration setting which was saying 7.1, not doublechecking with PHPinfo if that actually was the case…

So updating the cpanel settings seamed to renew the configuration to the its proper state…

Thanks for alle the help :sunny:

I assumed the same. :+1: