Password app - warning insecure password - Reverse proxy


I am running nextcloud 19 (with password app) on a VM behind a reverse proxy. When the password app finds an insecure password, an email is sent, but the link to change the password directs the user to the internal address of the VM or localhost. Please let the admin be able to set the link to the correct (external) hostname for the password app.

Best Regards
Stefan Sundberg

The app does not generate urls by itself and uses Nextclouds api for this instead.

Maybe you need to set overwrite.cli.url in your config.php. Take a look at this manual page:

I changed the parameter and it will probably work. Thank you.