Ownpad and etherpad options and installation

I’m trying to install ownpad to access etherpad from nextcloud. In owncloud documentation I found installation instructions. (https://github.com/otetard/ownpad/blob/master/README.md#mimetype-detection). Where are collaborative documents in nextcloud?

  • Is last version of etherpad (1.6.0) supported?
  • Can I also use custom add_ons for etherpad e.g. app_tables and will they for in nextcloud?
  • How can I manage access rigths for etherpad in nextcloud? (Is access open for all nextcloud users?)

Thank you for all your help.

As far as I understand ownpad, it’s just redirecting to etherpad/ethercalc instances so all addons should work and every version should be supported (I use a lot of addons and i dont have problems)

That depends on your etherpad installation. If etherpad is open to the public then no, you can’t. If it’s behind firewall and only ownpad has access to it then, people could interact only with the pads via their owncloud web interface (unless they guess the exact link). You can also use authentication for your etherpad instance (ldap, mysql etc) but I’m afraid that users would have to type the password each time they access the pad from nextcloud.
You can also restrict ownpad app itself to a certain group (when you enable the app in the nextcloud webinterface).

Thank you very much, but I still can’t find any installation instructions on Ownpad.
I extracted ownpad in nextcloud apps folder the same way I did with other applications but still can’t see it anywhere in nextcloud programs section or find anything useful in admin settings.
Can anyone help me with that?

Thanks in advance.

Did you enable it? If you don’t see it in APPS maybe you could check via commandline if app is enabled.
If so, you can check your admin settings under “Additional Settings” -> “Collaborative documents”. There you should specify url to your etherpad/ethercalc instances.
Once this is done, you will be able to start new pads form within nextcloud interface by pressing “+” button in your files app and selecting whether etherpad or calc.

I cannot enable it, because it’s not there. Extracted file (ownpad 10) is in apps directory on my disc, but not in nextcloud. Also I don’t have collaborative documents in my additional settings.

Is the app directory called ownpad?
If you have terminal access to your server I would recommend enabling the app via commandline.
First of go to your owncloud directory and run chown www-data:www-data -R apps/ownpad to make sure the ownership is correct.
Then you can check if the app is there by typing:
sudo -u www-data php occ app:list

If you can see ownpad, you can enable it by:
sudo -u www-data php occ app:enable ownpad

Thanks, that worked.
I also installed local instance of etherpad which is working. I specified it in collaborative documents and I assumed that opening a .pad file would open online editor but instead offers me to save file to my disc. Any advice on how to do that?

Thank you very much.

That’s what it does. Saves file on you nextcloud like this *.pad. once you click on it it will open etherpad.

*.pad is saved on nextcloud and when I click on it it forces download on my hard drive. In that saved file there is a text with: [InternetShortcut] URL=http://… I can only access this pad in online editor if I copy that url to my browser. How to do this automatically?

Did you also created mime files? I dont think this has been solved yet. check here https://github.com/otetard/ownpad/commit/2b324e050fd0862e7e08e34adc1341b44efeaed8

Thankyou for all your help. It works very well now.

Hi. I encountered another problem I cannot solve. Some addons installed through npm are working and when others are installed I get connection not allowed when trying to connect through nextcloud. When I remove them, etherpad starts working again. I tried with chown-ing but the problem remains. Any suggestions?