Owncloud -> Nextcloud with imap backend fails

Dear all,

I migrated now an owncloud installation to a nextcloud installation.
The site uses as user backend an imap server.

I followed the tips here.

  • Switched site to maintenance mode
  • copyied the config file over to the nextcloud installation folder
  • executed ./occ upgrade
  • switched maintenance mode off

If I access the site I get in owncloud.log the following entry:
{"reqId":"V2Zsc8MeXyEAAKQ8CG8AAADQ","remoteAddr":"185.17.205.xxx","app":"core","message":"User backend OC_User_IMAP not found.","level":3,"time":"2016-06-19T11:57:07+02:00","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","user":"idefix"}

In the config.php includes:
'user_backends' => array ( 0 => array ( 'class' => 'OC_User_IMAP', 'arguments' => array ( 0 => '{hostname:143/imap/tls/novalidate-cert}', ), ), ),
Does maybe anyone an idea how to get my site running with nextcloud?


Hi Matthias,

Thank you for your trust into Nextcloud. Are you sure that the “External Users” app is enabled on your Nextcloud instance? Try to execute: app:enable user_external with occ :wink:

Looking forward for hearing from you :smile: …you’re welcome here in our forums or on our freenode IRC #nextcloud :wink:


yes I’m sure:
`./occ app:list
ownCloud is in maintenance mode - no app have been loaded

  • activity: 2.2.1
  • admin_audit: 1.0.0
  • bookmarks: 0.7
  • calendar: 1.2.2
  • comments: 0.2
  • contacts:
  • dav: 0.1.6
  • documents: 0.12.0
  • encryption: 1.2.0
  • external: 1.2
  • federatedfilesharing: 0.1.0
  • federation: 0.0.4
  • files: 1.4.4
  • files_external: 0.5.2
  • files_pdfviewer: 0.8.1
  • files_sharing: 0.9.1
  • files_texteditor: 2.1
  • files_trashbin: 0.8.0
  • files_versions: 1.2.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • gallery: 14.5.0
  • notifications: 0.2.3
  • provisioning_api: 0.4.1
  • systemtags: 0.2
  • templateeditor: 0.1
  • updatenotification: 0.1.0
  • user_external: 0.4
  • user_ldap

I disabled it and enabled it again, but the same problem.

I copied now some apps from the old installation to the nextcloud installation and disabled them manually on the database.
The problem is now solved, the error message is gone.
I cannot really answer what I did, but maybe it was related to a missing app in the apps folder.

1 Like

:thumbsup: … however: have we changed anything in the apps (especially the user_external) that could cause this problems? @LukasReschke

I ran into a similar problem when attempting to install nextcloud from the git repo, the external app does not appear to be included in the repo, while it was included in the downloadable release.

Is the app not meant to be part of the base distribution?

user_external is not included in the Nextcloud Server (or ownCloud Core) :grin: It is currently part of the owncloud/apps repository :wink:

FYI @MorrisJobke

That’s correct, furthermore we don’t officially support installations from Git and highly advise against it. If you want the newest code base we recommend to regularly update to our daily builds.


Uhmm… Should we fork owncloud/apps for issue tracking etc.? I can do that :muscle: @LukasReschke

1 Like

thank you @LukasReschke for the clarification on that, I did notice the in-cloud updater detected git as the update method… I have since reinstalled from the downloadable archive.

@mar1u5 :+1: for an owncloud/apps fork!

I also just upgrdaded from OC 8.2.5 to NC .
To get the IMAP authentication working I had to enable it on the command line as it’s not shown in the web UI (?!)

No, it seems to be working find, but I see duplicated user accounts in the admintstration overview which worries me a bit.
Same username, but different fullname, group, quota, last login.

edit: Further investigation of this is discussed in another thread