Owncloud clients can not connect


I’ve just testing the migration of our owncloud (9.0.4 ) to nextcloud (fist 9.0.57, then 10.0.4). The migration worked without issues, and the web interface is up and running.

The only problem is that we have quite a big userbase with owncloud clients, and we are unable to connect them to the nc server. Web and nextcloud clients are working fine, but no owncloud client (I’ve tried windows, linux and android ones).

In the logfile I get one line like this each time I try to use an owncloud client

owncloud.log-20170610.gz:2017-06-09T13:15:24.609234+02:00 debug ehubox-test ownCloud[11965]: {webdav} Exception: {"Message":"HTTP\/1.1 401 No 'Authorization: Basic' header found. Either the client didn't send one, or the server is mis-configured","Exception":"Sabre\\DAV\\Exception\\NotAuthenticated","Code":0,"Trace":"#0 [internal function]: Sabre\\DAV\\Auth\\Plugin->beforeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#1 \/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 \/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(446): Sabre\\Event\\EventEmitter->emit('beforeMethod', Array)\n#3 \/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/apps\/dav\/appinfo\/v1\/webdav.php(60): Sabre\\DAV\\Server->exec()\n#5 \/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/remote.php(165): require_once('\/opt\/rh\/httpd24...')\n#6 {main}","File":"\/opt\/rh\/httpd24\/root\/var\/www\/html\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Auth\/Plugin.php","Line":188,"User":false}

I’m using RHEL7.3, with apache 2.4.25 and php 5.6 from the software collections

Any ideas?

The Nextcloud client only has a different branding, the functionality should be the same. I can still sync a 2.3.2 client to NC 12.0.0. There is only a problem if your users have very old client versions (<2.0) which should be updated. You can see in your webserver access log the version in the user agent string.

So there is perhaps a different issue. Did you review all the settings of your webserver? Perhaps try to connect to one of the test server (there are different NC versions available) if you connect with the owncloud client. If it fails, we have to investigate the client, if not we are back to the server configuration.

Support for NC 10.0 runs out by the end of this month, so you should soon upgrade to NC 11 which should be very stable by now.

I finally found it. It was all related to htaccess.RewriteBase.

In RHEL7 default httpd.conf has 4

AllowOverride None

lines. I have changed some of them in the past, but finally I changed all of the to

AllowOverride All

and everything is working now.

Thanks for the help