"overwrite.cli.url" warning after updating to NC v23.0.4.1

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.4.1
Operating system and version (eg, Ubuntu 20.04): Raspberry Pi OS Buster
Apache or nginx version (eg, Apache 2.4.25): nginx/1.14.2
PHP version (eg, 7.4): 8.0.18

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Update to NC v23.0.4.1
  2. Have no URL for overwrite.cli.url parameter set in config.php
  3. Check admin overview page

Hi, because of [stable23] Validate `overwrite.cli.url` to be a url in setup check by backportbot-nextcloud[bot] · Pull Request #31518 · nextcloud/server · GitHub I got a warning in the admin overview page.

In config.php I had: 'overwrite.cli.url' => '/',
I now changed it to my external hostname, which is mainly used.

…BUT I also access Nextcloud with the internal hostname (only inside local network) and now I’m wondering if there are any side effects of using the external hostname (the internet facing one, primarily used).

Up to now I could not detect any issues (accessing NC externally and internally/with both hostnames), just want to make this 100 % sure.

(also checked https://docs.nextcloud.com/server/23/admin_manual/configuration_server/config_sample_php_parameters.html?highlight=overwrite.cli.url of course)

Why did you set this parameter? Are you using a proxy?

Compare this to the documentation you linked above (and: https://en.wikipedia.org/wiki/URL).

This parameter forces all URLs to have the right name for the proxy, regardless the internal URL.

Why? Well that was 9 years ago when I initially set up the predecessor OwnCloud, don’t remember. But yes, I use nginx as a reverse proxy.

What was the intention of [stable23] Validate `overwrite.cli.url` to be a url in setup check by backportbot-nextcloud[bot] · Pull Request #31518 · nextcloud/server · GitHub? If we should use the “primarily used URL” in this parameter I’m good.

Or do you question if I need to use the overwrite.cli.url at all?

That would have been my question if you didn’t use a reverse proxy.

Yes, the problem then is, you have to use this URL all the time, you can access directly within a local environment (without using the reverse proxy).

I can still use my internal URL even with having this parameter set to the external one now. So far no side effects.

Setting the overwrite.cli.url to the main url is recommended. See server/setupchecks.js at dbdb9f6f11a32bc1643f302c44654076bd56db31 · nextcloud/server · GitHub. There should be no bad side effects.

1 Like

It is no good idea to use from the local network another name. If it is not possible to use the standard nextcloud external name, you should solve this problem. You can search Hairpinning and NAT Traversal.

I’ve got the same issue, doesnt matter what I configure, the warning remains.