Outlook Plugin not accepting credentials

Got NextCloud setup on a linux VM successfully (using IP & SSL, no domain name and no specific cert that matches the IP), and was able to install the android client and log in without issue.

Installed the Outlook x64 plugin and tried to login with a user - but consistantly get the error “The settings are incorrect. Please check the server url, username and password.”

What’s the best way to triage this?

Update: After I added a domain name and SSL certificate, it authenticated properly.

Update 2: After trying to setup on a separate machine, I can’t get past the error of “The settings are incorrect. Please check the server url, username and password”.

I can log in on any browser successfully, also the client app. I’ve attempted to use an App ID login, that failed as well.

Suggestions

thats the solution.

this is just a new thread

@update 2. How are you authenticating? Do you have a LDAP or SAML ‘back-end’?

Using the OOB user management, no back-end system.

Actually @JimmyKater, I’m not sure it is. My original machine that was authenticating properly no longer is.

well to have that plugin working correctly it is mandatory (afaik) to have a valid certificate…

Alright here are some ideas:

  1. Certificate invalid / self-signed. Either renew the certificate or make sure the self-signed certificate is installed in the root authority folder on your machine(s).
  2. Enable debugging. In Registry navigate to: Computer\HKEY_CURRENT_USER\Software\NextcloudOutlookFE, set ‘Debug’ to ‘true’ and restart Outlook. Log will be placed in the user their my documents directory.
  3. In case you use proxies make sure the default windows one is usd.
  1. Certificate is valid
  2. Logging is enabled - I don’t have the exact log handy right now, but it mentioned passing the auth request to the site, with the app id token. No explicit failures.
  3. No proxy used

After re-attempting the connection again today, it worked. I’m considering this solved by SSL certificate.