OpenSync / Xiaomi : Synchronization Issue

Hello everyone,

After 1 month searching what’s wrong with my configuration, I never found why I’m not able to sync my mobile to my NextCloud server.

My sync is ok with ThunderBird and my old phone. On my Xiami Redmi 4X I cant find my nextcloud agendas in the differents agenda lists in agenda apps. Even if i’ve synchronized my nextcloud account in OpenSync. I tried to uninstall, did it again, tried CallDAVDroid too.

I tried to use Opensync/DavDroid + Acalendar.

I’m tired of searching in google and everywhere, if someone know how to help me, i would be grateful.
Sorry for bad english.


Hello everybody,

I finally found what was the issue with Xiaomi mobiles. In the case it might help someone who have the same issue, I’ll explain here how to resolve this issue.

There are 3 importants options on MIUI* mobiles which could block you.
MIUI* : Android for Xiaomi mobiles.

The first one is authorization for apps, there is 2 authorizations :

  • Agenda acess authorization
  • Contacts acess authorization

You have to enable both to use Opensync for syncronization.
After this, the following log :

becomes :

The second one, is the auto-start options, you have to authorize Opensync to start automatically. You’ll find this option in security options.

Finally there is battery-save restriction, you can enable “no-restrictions” for your app, in the battery save options.

:warning: Here, you have to be careful to the sync interval*, it could be dangerous for your battery to disable restrictions if you don’t setup correctly your sync interval.
Sync interval* have to be configured in Opensync Accounts.

I found different solutions on different places and I don’t know if the 3 options are all necessary to get Opensync work correctly.

I advise to look at the 3 options if you really want to be sure the apps will synchronize like it should.



Thank you. It’s help-me, too… :wink:

You’re welcome :slight_smile:

With Android 9, this changes slightly:

Go to Settings > Apps & notifications > Special app access :

  • Choose “Battery optimisation”, and “all apps”, search “OpenSync”, tape and choose “Don’t optimise”

And into “Apps & notifications”, look at new for “OpenSync”, set “App permissions” for Calendar, Contacts, and ‘Additional permissions’.

Well done!

1 Like

For the french users, read in french this memo.