OnlyOffice with External Storage

Hey everybody,

i tried to connect some external storages via the app provided by nextcloud.
Everything connected fine and i can see and access every document.

But when i try to edit DOCX, XLSX or PPTX files, onlyoffice is starting and loading for some seconds but then i am recieving an download failed error.

With Storage Type FTP its working but when i try to open a file from an SMB/CIFS-Storage it is not.
OnlyOffice’ Troubleshooting page says the Path is incorrect, so there is an issue between external storage smb and onlyoffice!

I dont have any idea where the problem could be?
Probably loading the document takes to long? is there any option to increase the timeout time?

Thanks

Hi,

I have the same issue… as many others. Take a look here and there:

https://github.com/ONLYOFFICE/onlyoffice-owncloud/issues/9

This article describe how the app works and might give some clues on why it does not work (yet) with external storage:

https://github.com/ONLYOFFICE/onlyoffice-owncloud

You can read that at one point of the process, it goes like this:

Then ONLYOFFICE Document Server downloads the document from ownCloud/Nextcloud and the user begins editing

I guess the problem here is that the samba storage requires some privileges to read files from. Nextcloud has the proper credentials to do so (given by the external storage plugin) but OnlyOffice has not.

One way would be that ether Nextcloud shares this credentials with OnlyOffice (kind of SSO) or Nexcloud shoulds behave as a file transfer proxy for OnlyOffice, or share credentials should be directly mentioned in OnlyOffice config file.

I have tried to do the same with Collabora Online and I have the exact same behaviour. On both solutions - ether OnlyOffice or Collabora - opening a docx/xlsx file from Nextcloud native storage works like a charm. But as soon as I move these same files on an external samba share, both document servers return the same kind file access error message while tring to proceed.

Anyway, so far so bad. And this is really a big issue for me: all my users have their files stored on samba shares with ldap access rules. There is no way I can migrate the whole stuff on a Nexcloud native storage. So my only way out is that the OnlyOffice or the Collabora app works with external shares.

To be honest, I would prefer to use OnlyOffice over Collabora. I find Collabora document server to be far behind OnlyOffice. OnlyOffice was much easier to install for me (they both run on the same Debian9), and over all, OnlyOffice has much more user funtionnalities, feeling close to your home desktop office suite. OnlyOffice is also better good looking imo. But at the end, it’s a question of piority: if Collabora works with samba share and OnlyOffice do not, I will pick up the winner.

Hi there,

Is there any chance to see either OnlyOffice or Collabora working with smb/cifs Nextcloud shares ?

I want to bump this. Has anyone got the document server /onlyoffice to work with external shares. When I try and open any doc on an external share it switched to the document server, but then I get the attached error.

If I open a file within nextcloud is works fine, but most of my users use a samabAD fileserver and access their files via nextcloud external shares. Any help would be awesome.
Capture

I founds an answer, not perfect, but it gets rid if the error, using the saved login creds doesn’t work, I have to use “Username” and “Password” Then it works!