OnlyOffice Versioning history - problem "Opening Document"

I am using nextcloud installed on Ubuntu 20.04 with nginx according to the documentation and it all works well.
I have setup APCu and Redis caching.
However - when I open docx document with onlyoffice - it opens fine and can be rad/write. But when I try to open the Collaboration → Versioning menu to see document versions - I get the “Opening Document” message and spins indefinitely. Strange thing here is is not crashing or reporting any errors over the logs. Nextcloud is working and can click and get back to files and folders - only OnlyOffice seems stuck during this indefinite opening.
Nextcloud is latest - 22.2.0 with latest apps for onlyoffice installed.

Can someone suggest what is the problem and how to fix it?
I have tried to disable all kinds of memcaches I am using but with no success.
I haven’t changed any onlyoffice settings - just installed and it was working by default fine until I discovered this problem.

Here is some screenshot of the problem:
Screenshot 2021-10-28 at 2.50.43

@ rlucassen
@ Vedran_Dobos
I saw you guys were having the same problem - were you able to resolve it and if yes - how?

We’ve had a similar issue with versions, updating to the latest OO (6.4.1-45) fixed it. Could work if you do not run that version yet.

@mvv_vmd I am actually using the documentserver app from the market - the one that is fast and easy to install and setup and it comes with this version. I assume you are using a separate standalone installation of onlyoffice document server connected to nextcloud?

The Community Document Server app? That one is very broken from the start. It does not save files properly to begin with. I don’t think it is maintained either. Best to switch a different version like the docker image or local install if you are.