OnlyOffice SSL Error


Just installed Nextcloud 18.0.3 via snap (18/edge). The server is an Ubuntu 18.04 VM on a Centos 8 host.

All is running well and I setup https with letsencrypt. However, I cannot start OnlyOffice as it fails with the following error:
cURL error 51: SSL: certificate subject name ‘my.fancy.domain’ does not match target host name ‘’ (see

hostnamectl gives my.fancy.domain, and etc/hosts shows localhost and my.fancy.domain

No other issues with letsencrypt. Any suggestions would be appreciated.


As an update, I tried re-running nextcloud.enable-https lets-encrypt to make sure I entered my.fancy.domain in and it still does not work.

The certificate is correct and it shows it is signed by the domain. The target host name that nextcloud is directing to is somehow wrong - it is trying to reach the site on the local IP address, not from the domain.

Any ideas?

I’m not familiar with setting up Nextcloud via a snap package. Is Onlyoffice baked into the snap?

How are you trying to reach Onlyoffice? What address did you type into the OO settings within Nextcloud settings?

Somewhere you are using the IP address – you need to be using a domain name – specifically the domain name on the cert to connect

Thank you for your reply - that actually made me wonder. It turns out in 18/edge OnlyOffice is included, but the configuration is slightly off.

In Nextcloud, I went to Settings–>OnlyOffice and had to change the addresses to my.fancy.domain instead of their local address. This was it - it immediately worked!