OnlyOffice plugin needs me to save settings every day to keep connectivity alive

Nextcloud version : 27.1.2
Operating system and version :
lscr.io/linuxserver/nextcloud Docker Container
Apache or nginx version : Nginx Proxy Manager v2.10.4
PHP version : 8.2.10

The issue you are facing:

I have setup nextcloud to connect to OnlyOffice document server.
They both rest on Docker containers in the same docker network.
They see each other without issues. And I am able to edit documents without problems.
However every day I have to go back to the Netxcloud Admin Settings and inside OnlyOffice plugin settings click on save for Nextcloud to recconect with the OnlyOffice document server. Otherwise I won麓t be able to click on a document to edit it, it will instead download the document.
Is there a way to avoid this? it doesn麓t seem like normal behaviour

Steps to replicate it:

  1. Just install Nextcloud with OnlyOffice Document Server

The output of your Nextcloud log in Admin > Logging:

{"reqId":"uzbreJTzyA7nFTDbTGF3","level":3,"time":"2023-10-27T08:30:05+00:00","remoteAddr":"","user":"--","app":"onlyoffice","method":"","url":"--","message":"GetConvertedUri on check error","userAgent":"--","version":"27.1.2.1","exception":{"Exception":"Exception","Message":"Error occurred in the document service: Error while downloading the document file to be converted.","Code":0,"Trace":[{"file":"/config/www/nextcloud/apps/onlyoffice/lib/DocumentService.php","line":95,"function":"ProcessConvServResponceError","class":"OCA\\Onlyoffice\\DocumentService","type":"->"},{"file":"/config/www/nextcloud/apps/onlyoffice/lib/DocumentService.php","line":446,"function":"GetConvertedUri","class":"OCA\\Onlyoffice\\DocumentService","type":"->"},{"file":"/config/www/nextcloud/apps/onlyoffice/lib/Cron/EditorsCheck.php","line":145,"function":"checkDocServiceUrl","class":"OCA\\Onlyoffice\\DocumentService","type":"->"},{"file":"/app/www/public/lib/public/BackgroundJob/Job.php","line":81,"function":"run","class":"OCA\\Onlyoffice\\Cron\\EditorsCheck","type":"->"},{"file":"/app/www/public/lib/public/BackgroundJob/TimedJob.php","line":103,"function":"start","class":"OCP\\BackgroundJob\\Job","type":"->"},{"file":"/app/www/public/lib/public/BackgroundJob/TimedJob.php","line":93,"function":"start","class":"OCP\\BackgroundJob\\TimedJob","type":"->"},{"file":"/app/www/public/cron.php","line":152,"function":"execute","class":"OCP\\BackgroundJob\\TimedJob","type":"->"}],"File":"/config/www/nextcloud/apps/onlyoffice/lib/DocumentService.php","Line":241,"message":"GetConvertedUri on check error","CustomMessage":"GetConvertedUri on check error"},"id":"653b865d1d66e"}

I am having the same problem, the version of Nextcloud that I have installed is 27.1.3 and that of Onlyoficce is 7.5.0.125, they are installed in separate virtual machines within the same LAN network. Nextcloud is placed daily in maintenance mode to make data backups. I have tried to activate the Onlyoffice plugin through OCC but it does not connect, it only works by pressing the Save button within Nextcloud.

As a workaround I have created a python script that does this task (connect to Nextcloud and press the save button on onlyoffice plugin setup) and I have schedule it so I don麓t need to press save every day, but is far from an acceptable solution in my opinion.
This is the code in case you want to use it.

from selenium import webdriver
from selenium.webdriver.common.keys import Keys
from selenium.webdriver.common.by import By
import time

#Constants
MAIN_URL = "https://your.url.com/"
#Admin credentials
my_username = "your_admin_username"
my_password = "your_admin_password"
PLUGIN_RELATIVE_URL = "settings/admin/onlyoffice"

#Main Program
fireFoxOptions = webdriver.FirefoxOptions()
fireFoxOptions.add_argument('-headless')
fireFoxOptions.page_load_strategy = 'normal'
driver = webdriver.Firefox(options=fireFoxOptions)

#open github.com login
driver.get(MAIN_URL + "login")

#access github login username input
username_input_box = driver.find_element(By.ID, "user")

#access github login password input
password_input_box = driver.find_element(By.ID, "password")

#access github signup button
sign_up_button = driver.find_element(By.XPATH, "//button[@type='submit']")

#clear the placeholders data
username_input_box.clear()
password_input_box.clear()

#fill login credentials
username_input_box.send_keys(my_username)
time.sleep(1)    #2 second time gap between filling username and password
password_input_box.send_keys(my_password)

time.sleep(1)    #2 second time delay

#hit the login button
sign_up_button.click()
# automatically close the driver after 30 seconds
time.sleep(4)

#open onlyoffice plugin settings
driver.get(MAIN_URL + PLUGIN_RELATIVE_URL)
time.sleep(2)    #2 second time delay

#locate save button
save_button = driver.find_element(By.ID,"onlyofficeAddrSave")

#hit the save button
save_button.click()
time.sleep(2)    #2 second time delay

driver.close()

You only need to edit MAIN_URL, my_username and my_password.
Keep the rest of the script as it is.
You will need Python3, Selenium and Firefox.

https://github.com/ONLYOFFICE/onlyoffice-nextcloud/issues/864

Some other issues related : Every day at a random time the connection to OnlyOffice in NextCloud is disconnected 路 Issue #917 路 ONLYOFFICE/onlyoffice-nextcloud 路 GitHub

If I understand well, set this parameter :

sudo -u www-data php occ config:system:set onlyoffice editors_check_interval --value=0

(And not sudo -u www-data php occ config:app:set onlyoffice editors_check_interval --value=0 apparently)

And we have to wait that this PR (code modification) is merged for future release : editors check interval fix by rivexe 路 Pull Request #965 路 ONLYOFFICE/onlyoffice-nextcloud 路 GitHub
At the moment, it鈥檚 merged in 鈥渄evelop鈥 branch, not master and I don鈥檛 know their flow. Last version of Onlyoffice app was in december, so hopefully, we will get a new version soon.

We had the same issue. Stopping the Log-Rotate (in cron) on the OnlyOffice-Server solved the problem. We are still searching for a solution but for now it is better to manually restart the webserver on OO-Server manually and reset the Parameters on Nextcloud.

If we found a solution ill let you now.

regards,
marc