Onlyoffice one click install not working

Hello,

I tried to install Onlyoffice by following the instructions on the blog, with the “one click” function:

Once installed it doesn’t work, I can’t directly edit my files. I looked in the settings and it kept the old link of my onlyoffice, if I try to delete it and save it it comes back permanently. I also tried to install the plugins the other way around.

I don’t see any error in the logs, either when installing the 2 plugins or when saving the settings in the administration page.

Nextcloud version: 19.0.0
Reverse proxy: Apache
Database: Postgres

For information I used to use onlyoffice manually installed before and it worked very well.

I also tried this comment: NC18 clean installation but ONLYOFFICE doesn't work?

Why didn’t you stick with it?

This uses me an ipv4 address and I would prefer to have everything on one machine.

The other reason is that updates are much easier from nextcloud.


Small update I think I managed to remove the old URL by uninstalling the plugins several times. I now get an “Access denied” error when I try to save the settings.

I tried to delete all the fields again, to delete only the URL, to delete the key, but it doesn’t change anything I’m stuck…

I also am at the same place, anyone know an answer?

I wanted to try to solve the problem directly in the database. I read that the fields had to be empty when you clicked on save (How to install ONLYOFFICE in Nextcloud Hub and new integration feature). So I thought I would uninstall the plugins, delete the configuration of the fields where I have problems with it, and reinstall the plugins.

Unfortunately it didn’t work either:

sudo -u www-data php /var/www/nextcloud/occ app:remove documentserver_community
sudo -u www-data php /var/www/nextcloud/occ app:remove onlyoffice

update public.appconfig set configvalue = '' where configkey = 'jwt_secret' ;
update public.appconfig set configvalue = '' where configkey = 'DocumentServerUrl' ;

root@box:~ # sudo -u www-data php /var/www/nextcloud/occ app:install
documentserver_community && sudo -u www-data php /var/www/nextcloud/occ app:install onlyoffice
documentserver_community installed
documentserver_community enabled
onlyoffice installed
onlyoffice enabled

Hey guys,

If you want to revert to the old way (Docker), then here’s a script for you:

Please remember to backup your system before, or at least make a snapshot if you run it as a VM.

Thanks for the feedback @enoch85.

But I don’t understand why you’re talking about going back to the Docker. Before I wasn’t using Docker but the manual installation on another server (which is still operational by the way). I’ve put back my old configuration to have access to Onlyoffice again.

The message I posted with the attempt to delete the values in the database is to set up Onlyoffice with the “Community Document Server” via plugins. I don’t want to use the manual installation or Docker anymore but the new plugin method.

Thanks anyway for the link I discovered some interesting commands.

If you want to do it the new way (just the app) there’s a script for that as well:

I’ve just executed the last script by doing a reinstall and it doesn’t work any better …

This morning I just tried again to set up onlyoffice via the plugin and this time all works perfectly. I don’t understand what I did differently… but I think your script must have helped.

1 Like