Onlyoffice on ubuntu 20 as lxd

i have a ubuntu 20.04 (lxd ). i install nexcloud on it. i try to install onlyoffice in same server
but in documentation for nextcloud 20 says no need installation for onlyoffice. add this from administrator apps and run the command :
sudo -u www-data ./occ app:install onlyoffice
“onlyoffice already installed”
but it’s not look like. which url should type in site definition.

Hi @bahman_shahrzad_asr you can install Community Document Server by using apps installer of nextcloud on the web page ( check the description of this app for more detail about it :
onlyofficeapps

or install ONLYOFFICE Docs Community Edition ( server ) check this link: Installation Guides - Docs - ONLYOFFICE

for my part, I have installed the server of onlyoffice Docs Community Edition

after installing the apps or server you need to install Onlyoffice app with the apps menu :

if you have choose the Community Document Server apps according to the github of the apps :

" The community documentserver will automatically configure itself if no other document server is configured in the onlyoffice settings (“Document Editing Service address” is empty). All other “Server settings” should be left empty. "

i used documentet and install it on port 88. installation was success. and it repond on page
http://“ip”:88 i don’t using https now.
Then i try to write server info in onlyoffice for nextcloud i type http://“ip”:88
error : Error when trying to connect (cURL error 3: (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)):heavy_multiplication_x:

help

Hi @bahman_shahrzad_asr
here is my onlyoffice configuration web page :

in advanced server settings :

  • set first the URL of document server: you can use http://127.0.0.1:88 ( mine is on 8082 port)
  • set the URL of your nextcloud instance: in my case htpp://127.0.0.1/

127.0.0.1 is the localhost of your machine ( internal IP )
both servers are on the same machine so we can use it

very strange dosn’t matter what i do it’s comming error " Error when trying to connect (Host violates local access rules)"
i wrote ip:88 same error
i create https and certificate the i wrote https://ip same error.
i stop nginx and write ip:88 same error it’s look like don’t connect to document-server but
i have respond from https://ip comming to welcome page.

@bahman_shahrzad_asr
maybe by adding this into your config.php can solve the issue :
‘allow_local_remote_servers’ => true,

yes it was that thank you thank you thank you.

1 Like