OnlyOffice: Error while downloading the document file to be converted

Hello everybody,

I’m in the process of installing a Nextcloud.
Unfortunately, I come to repeatedly a problem with OnlyOffice.

I have a server running an Apache2 listening on port 443.
On this server, Nextcloud is deployed as VHost with the domain: cloud.mydom . com. In addition, Docker is still running on this server and should provide onlyoffice. Onlyoffice is provided internally via port forwarding from port 80 to 81, and is available via Apache’s other hosts as onlyoffice . mydom . com.

Unfortunately I get the following error message:
GetConvertedUri on check error: An error has occurred in the document service: Error while downloading the document file to be converted.

OnlyOffice is set up as follows:
docker run -i -t -d -p -e JWT_ENABLED = ‘true’ -e JWT_SECRET = ‘secret-secret’ --restart = always onlyoffice / documentserver

ApacheConfig looks like this:
<VirtualHost *: 443>
ServerName onlyoffice . mydom . com

        ProxyPass / http:// /
        ProxyPassReverse / http:// /

        SetEnvIf host "^ (. *) $" THE_HOST = $ 1
        RequestHeader setifempty X-Forwarded-Proto https
        RequestHeader setifempty X-Forwarded host% {THE_HOST} e
        ProxyAddHeaders Off

        SSLProxyEngine On
        SSLProxyCheckPeerCN off
        SSLProxyCheckPeerExpire off
        ProxyPassMatch (. *) (\ / Websocket) $ "ws: // 81 / $ 1 $ 2"

        ErrorLog $ {APACHE_LOG_DIR} /error.log
        CustomLog $ {APACHE_LOG_DIR} /access.log combined
        SSLCertificateFile /etc/letsencrypt/live/
        SSLCertificateKeyFile /etc/letsencrypt/live/
        Include /etc/letsencrypt/options-ssl-apache.conf
</ VirtualHost>

When I visit https:// onlyoffice . mydom . com, I get the message that onlyoffice is running.

Testweise I have tried the following:
I have newly created the Docker container, but this time without a password:
docker run -i -t -d -p --restart = always onlyoffice / documentserver

If I delete the password in Nextcloud now, it works.
The SSL certificates of Apache come from Letsencrypt. Apache and the DockerContainer communicate via http.

In the Netxcloud config.php I have entered the domains with:
‘trusted_domains’ =>
array (
0 => ‘cloud . mydom . com’,
1 => ‘onlyoffice . mydom . com’,
onlyoffice’ => array (
‘verify_peer_off’ => true

I have already tried the following:
In the Docker container, the /etc/onlyoffice/documentserver/default.json
the value “rejectUnauthorized”: changed from true to false

Does anyone have any idea how I can fix the problem?
I am surprised that it works without a password, but not with …
Many thanks for your help