OnlyOffice / Document Server does not work

After dealing with the cURL timeout, I was able to download the document server on my Ubuntu 18 box (Hansson Hyper-V), but I cannot work with it. Selecting an office file still gives me only the possibility to download the file. In the error log I see the following:

The configuration menu is not complete (on another (working) box I see below “Common Settings”):

Has someone else faced this problem or can help?

Thanks in advance

again and again and again: have you tried installing and activating onlyoffice-app as well?

Of course. Otherwise I couldn’t have created the second screenshot, right? I deactivated, removed downloaded and activated both components for several times.

The community documentserver will automatically configure itself if no other document server is configured in the onlyoffice settings (“Document Editing Service address” is empty). All other “Server settings” should be left empty.

Have you added the service address to onlyoffice or did that the docummentserver?

sorry. that wasn’t clear for me.

a more direct hint like e.g. “i have read several issues here dealing with the same problem but all solutions there haven’t worked for me” would have been better and preferred.

Just wanted to link this to my post where I discuss this same issue:

So far I haven’t found anything that resolves this issue for me.

The very same is happening here.

Coming from Nextcloud 17.02 and upgraded according to
The upgrade went nice and smooth, all other apps are working as expected.

Still: Opening doc, docx, xls etc. result in just downloading the files but not opening them. Nothing inside nextcloud.log although all log-options are activated.

Running out of ideas here how to solve this.

1 Like

@Copeman do you have any other apps? I had the full text search that was conflicting with only office. I could only download office files, I disabled that and its started working

What did the trick for me was just hitting the save button in the document server settings.
So the server address was filled automatically, I just hit save to see what happens and see if error messages come up and that actually solved the problem of files just being offered for download before. Now they open in onlyoffice.

Hope that works for you, too.


OMG! Such a simple trick. Works like a glance now. Thanks for figuring this out.

We are happy to hear that Schmu’s simple trick did solve it for you.

Unfortunately on two Nextcloud-servers we are managing (dedicated root-servers on Ubuntu 18.04, Apache 2.4.41 (mpm-event) , PHP 7.3.13 (FPM/FastCGI)) the “solution” is going nowhere.

The document server is not firing-up and a click on office-files is downloading them instead of opening the files for online editing.

Also an update to Community Document Server v0.1.2 does not solve the problem.

I did what @Schmu suggested. But unfortunately I still get this error: “(cURL error 6: Could not resolve host: onlyoffice-document-server (see”

Iam running NC 18.0.0 in a docker environment. What URLS do i have to fill in? I tried a few but no success so far…

Hi @anotherncuser

For some reason the address to your document server is not correct/ valid. I had the onlyoffice app installed before, installed the community server afterwards and that wrote the correct address into that field automatically.
The address should be like:

Your entries under “Erweiterte Servereinstellungen” don’t seem right as well.
Try this but adept to your domain:

I think installing of community document server should be dependent on onlyoffice connector, that means, the system should check its installation and active status, if not, to improve the state and install if necessary it.

1 Like

thats true and thus an issue about it was already filed on github

To close our problem within this thread: jsdfkljklj found the culprit which is the app Full text search - Files which doesn’t let OnlyOffice Community Edition start as it should.

After disabling “Full text search - Files” OpenOffice works as expected.

1 Like

Okay that is my Solution. But i also need FTS. I hope they can fix it

Deleting “Document Editing Service address” or appending “/apps/documentserver_community/” solved the issue.

Tried both, doesn’t work here. As soon as Full text search - Files is enabled OpenOffice is not working anymore.

Got the same error. None of the tricks mentioned here work. I run Nextcloud via the Webserver of my Synology NAS. At work, the Nextcloud and OnlyOffice instances on our Synology NAS don’t work as well.

I tried changing permissions for docbuilder and x2t (pre 1.0.2 fix), I tried saving the settings, I tried playing around with the URLs in the settings, nothing works. I get

“Community document server is not supported for this instance, please setup and configure an external document server”

all the time. That’s further away from “fully integrated, just works” than I ever could have imagined. And I was really hoping to find a great collaboration tool for our students at school.