OnlyOffice and Printing

Hi ,

I have no problem creating en editing documents in onlyoffice but when i want to print a document i get the message

Warning
You are trying to perform an action you do not have rights for.
Please contact your Docuemnt Server administrator.

I allready setup working with secret key, but this made no difference. I googled my ass of but could find the solution.

furthermore i installed the latest docker version (document editor 5.4.0) and the latest nextcloud (16.0.4). The nexcloud app version is 2.4.0

Have someone printing working within onlyoffice started from nextcloud.

Thanks in advance

Gerard

1 Like

Is the NC app “printer” working? I’m just asking that to get an idea of you can print at all on your server.

With Onlyoffice in a docker container it could be necessary to open the port for printing on the docker container.

Just giving this as an idea where to look for solutions. I haven’t tried printing myself yet and therefor have no real solution.

Still no luck with printing or “Save document as”

I still get the message:
Warning
You are trying to perform an action you do not have rights for.
Please contact your Docuemnt Server administrator.

Even change of the source code of the file …/apps/onlyoffice/controller/editorcontroller.php line 646 and 647 (change false into true)
if (method_exists($share, “getHideDownload”) && $share->getHideDownload()) {
$params[“document”][“permissions”][“download”] = true;
$params[“document”][“permissions”][“print”] = true;

Didn’t solve my problem. I hope someone can help me with this problem.

Perhaps this is related - meaning ‘save as’ and ‘printing’ (guessing that printing means for onlyoffice: creating a pdf and opening the browser print dialog).
And my search would be somewhere in the directory permissions.

  1. in nextcloud. What are they for the data-directories?
  2. if that is good for your webserver to write - what about your docker installation? Can onlyoffice write cache-files to the underlying filesystem? Are you running docker as root or as a special docker-user?

In retrospect I would perhaps check 2 before 1.

Best, Bernd

Hell @GHeiner
Did you find a solution for this problem? I face the same issue…

I had the same issue and was able to solve it by checking our Sophos UTM WAF (Web Application Firewall) logs. :face_with_monocle:

There were some security exceptions logged whenever I wanted to “print” or “save as” a Onlyoffice document. So I had to add some specific skip-rules to our firewall and then the errors were gone.

Let me know if you are interestet in these specific Sophos UTM skip-rules.

We have a regular Nextcloud installation (VM) and a Onlyoffice (Docker) behind a nginx reverse proxy (Docker) environment with both https and valid certificates.

Thank you very much Stefan for this Input. It works now after I changed config on our Sophos Firewall for the related Webserver…

1 Like