Onlyoffice and nextcloud on one raspberry pi3?

can i install onlyoffice on the same raspberry pi, where i have nextcloud installed? and is this working? or in other words: are 1GB (1,4GB or so with zram) ram enough for installing both? and is that smooth or lagging?

if it is to ressouceheavy, is there a alternative?

because i want to use nextcloud instead of google drive (and google docs)

thank you :heart:

I wouldn’t personally as it’s not light on resources.

is there an alternative app?

Texteditor, Markup, …

If you want a look and feel, you can install NC on a virtual server and give it different amount of memory. IntelNUC are nice devices (there are many other similar products) but it much more expensive than a raspberry (starts around 200€ + ram + harddrive).

What is so great with google docs, I’m happy when I don’t have to use it.

yea thats a great idea… but i dont want new hardware at this time…

intel nuc --> whislist :+1:

i like google doc because you can writel live together with other people in a group. and its a very well web app.
(in my oppinion much better than microsoft office and that for free)

i know its not the safest but I dont care lol :stuck_out_tongue:

If you’re short on funds, look at saving up for old, used HP Proliant or Dell servers. I got an HP Proliant ML110 G6 for $120 (warrantied too!) and it has a 4-core Xeon, 4GB DDR3 ECC memory and a 300GB HDD. I upgraded my RAM to 16GB for about $100, had an extra SSD laying around and did 2TB enterprise drives (Manufacturer refurbished WD Golds for $50/ea) in a mirrored ZFS array which set me back I think $320, or $400 if I had to pay for the SSD. Haven’t tried it with Onlyoffice, but it runs Nextcloud, SAMBA, Plex, and a Minecraft server very well. Just my $0.02 :slight_smile:

2 Likes

Maybe an old HP Microserver is a good choice too. They are very reliable server-grade hardware for the same price of an Intel NUC.

Aside from that, there are no ARM versions of Onlyoffice and Collabora CODE. They are considered to be too resource intensive for ARM SBC type systems.

There is also the old “dead undead” Documents app for Nextcloud. I don’t know if it works with NC 12 already:

1 Like

I have an Odroid XU4 running Debian Jessie and NC 12 and have successfully compiled OnlyOffice on that platform (that is, almost successfully, there are some issues which still need to be resolved, see here https://github.com/ONLYOFFICE/DocumentServer/issues/152, https://github.com/ONLYOFFICE/onlyoffice-owncloud/issues/96).

Compiling takes an awful long time, but I can confirm that performance-wise, OnlyOffice works well on this ARM-based platform. XU4 is faster than Raspberry, but cheaper than an Intel NUC.

Would be great if more people would try to compile/run OnlyOffice on ARM-based platforms, such that we can get to a fully working image eventually.

Dear pi-xel,
how did you compiled?
As i have tried on my opi+2e without any success.
Please guide/assist me how to do it?
thanks in adv

I don’t remember all the exact steps, but I have roughly followed the instructions on https://helpcenter.onlyoffice.com/server/linux/document/compile-source-code.aspx.

Especially the first step (compiling 3rd party apps) was a bit challenging because it makes use of precompiled executables and library files by default, which I had to compile or download manually for ARM. This includes ICU, CEF and V8 (the first two I compiled on my board, V8 I cross-compiled on my laptop).

For the rest, I was not able to use GCC 4.9, because I got an internal compiler error when compiling core, so I switched to GCC 6.

This is what I remember, if you run into other problems please feel free to ask. Would be interesting to see if you get a fully working DocumentServer or whether you can reproduce the problems I mention in the previously referenced threads.

Dear pi-xel,
can you please go breifely and guide me,
Please if you can check and let me know the exact steps u did from starting till end

till here everythings seems to be good
CXX(host) /home/user/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o
make[1]: /home/user/DocumentServer/core/Common/3dParty/v8/v8/third_party/llvm-build/Release+Asserts/bin/clang++: Command not found
testing/gtest.host.native.mk:175: recipe for target ‘/home/user/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o’ failed
make[1]: *** [/home/user/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o] Error 127
make[1]: Leaving directory '/home/user/DocumentServer/core/Common/3dParty/v8/v8/out’
Makefile:312: recipe for target ‘native’ failed
make: *** [native] Error 2
please guide

In some Makefile it is defined to use a cmake precompiled for x86 which does not work on Arm. Change it to a cmake compiled for Arm and it should finish.

please guide, i am noob in this
can you tell me how to do it?

i AM TRYING IT ON OPI+2E WITH ARMBIAN 5.31 stable Ubuntu 16.04.3 LTS 4.11.5-sun8i
Failed to fetch file gs://chromium-clang-format/8b68e8093516183b8f38626740eeaff97f112f7e for v8/buildtools/linux64/clang-format. [Err: /home/USER/DocumentServer/core/Common/3dParty/v8/depot_tools/vpython: line 12: /home/USER/DocumentServer/core/Common/3dParty/v8/depot_tools/.cipd_bin/vpython: No such file or directory
]
0> Failed to fetch file gs://chromium-clang-format/8b68e8093516183b8f38626740eeaff97f112f7e for v8/buildtools/linux64/clang-format, skipping. [Err: /home/USER/DocumentServer/core/Common/3dParty/v8/depot_tools/vpython: line 12: /home/USER/DocumentServer/core/Common/3dParty/v8/depot_tools/.cipd_bin/vpython: No such file or directory
]
Downloading 1 files took 8.145673 second(s)
Error: Command ‘download_from_google_storage --no_resume --platform=linux* --no_auth --bucket chromium-clang-format -s v8/buildtools/linux64/clang-format.sha1’ returned non-zero exit status 1 in /home/USER/DocumentServer/core/Common/3dParty/v8
make[1]: Entering directory '/home/USER/DocumentServer/core/Common/3dParty/v8/v8/out’
CXX(host) /home/USER/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o
make[1]: /home/USER/DocumentServer/core/Common/3dParty/v8/v8/third_party/llvm-build/Release+Asserts/bin/clang++: Command not found
testing/gtest.host.native.mk:175: recipe for target ‘/home/USER/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o’ failed
make[1]: *** [/home/USER/DocumentServer/core/Common/3dParty/v8/v8/out/native/obj.host/gtest/testing/gtest/src/gtest-death-test.o] Error 127
make[1]: Leaving directory '/home/USER/DocumentServer/core/Common/3dParty/v8/v8/out’
Makefile:312: recipe for target ‘native’ failed
make: *** [native] Error 2

PLEASE GUIDE

Hello,

I try it myself on my pc to compile it on my PC. which parts must I change to make it compatible with the arm64 architecture?