OneDrive Integration Crashed my install

Installed the OneDrive integration module & now the nextcloud install has crashed.

I cant even log in to the web interface now

I tried to see if i could uninstall from command line but why i ran the occ command i got this

 sudo -u www-data php /var/www/html/nextcloud/occ app:list
An unhandled exception has been thrown:
Error: Interface 'OCA\Files_External\Lib\Config\IBackendProvider' not found in /var/www/html/nextcloud/apps/files_external_onedrive/lib/AppInfo/Application.php:38
Stack trace:
#0 /var/www/html/nextcloud/lib/composer/composer/ClassLoader.php(444): include()
#1 /var/www/html/nextcloud/lib/composer/composer/ClassLoader.php(322): Composer\Autoload\includeFile()
#2 [internal function]: Composer\Autoload\ClassLoader->loadClass()
#3 [internal function]: spl_autoload_call()
#4 /var/www/html/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(108): class_exists()
#5 /var/www/html/nextcloud/lib/base.php(644): OC\AppFramework\Bootstrap\Coordinator->runRegistration()
#6 /var/www/html/nextcloud/lib/base.php(1091): OC::init()
#7 /var/www/html/nextcloud/console.php(49): require_once('/var/www/html/n...')
#8 /var/www/html/nextcloud/occ(11): require_once('/var/www/html/n...')
#9 {main}

I haven’t seen any related issues on the bug tracker of this app:

You use the latest version of the app and Nextcloud 20 (latest version)?

BTW I’m having the same problems.

<–! Paste this in GitHub report -->

NextCloudPi diagnostics

PHP Fatal error:  Interface 'OCA\Files_External\Lib\Config\IBackendProvider' not found in /var/www/nextcloud/apps/files_external_onedrive/lib/AppInfo/Application.php on line 38
NextCloudPi version  v1.34.7
NextCloudPi image    NextCloudPi_09-05-20
distribution         Raspbian GNU/Linux 10 \n \l
automount            yes
USB devices          sda
datadir              /media/ssd/data
data in SD           no
data filesystem      btrfs
data disk usage      3.6G/224G
rootfs usage         2.7G/59G
swapfile             /var/swap
dbdir                /media/ssd/ncdatabase
Nextcloud check      error
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       ok
port check 80        open
port check 443       open
IP                   ***REMOVED SENSITIVE VALUE***
gateway              ***REMOVED SENSITIVE VALUE***
interface            eth0
certificates         ***REMOVED SENSITIVE VALUE***
NAT loopback         no
uptime               31min

Not sure how to fix it yet. Can anyone give me a hint? :sweat_smile:

Thanks in advance :slight_smile:

Well, guess I’ve found a way to fix it, don’t know if it’s a rather dirty fix :sweat_smile:

I just deleted the folder with the app, so basically

sudo rm -R /var/www/nextcloud/apps/files_external_onedrive

Hope it helps if someone else has the same issue.

I’ve got the same problem with the sharepoint-app. Deleting the app fixed the problem, but it can’t be the solution. I have found similar problems here in the forum with all “sharepoint apps”, even with previous releases, without a proper solution to it.