ODROID N2 Docker stuck at initializing for the first time using NCP

Hello guys. I’ve owned a ODROID N2 with Ubuntu 18.04.2 LTS and wanted to install NextCloudPi. The first thing I did was to install docker:

curl -fsSL https://get.docker.com -o get-docker.sh
sudo sh get-docker.sh

I’ve forwarded the ports 80, 443 and 20 in my router (FritzBox).

After that I did what the instructions said:

docker run --restart=always -d -p 4443:4443 -p 443:443 -p 80:80 -v /media/storage/data:/data --name nextcloudpi ownyourbits/nextcloudpi-armhf 192.168.178.47

But after that I could see that it seems to work: System config value trusted_domains => 6 set to string 192.168.178.47

But after that when I go into the docker container and use ncp-config to get into ncp-info:

NextCloudPi version  v1.10.0
NextCloudPi image    NextCloudPi_docker_03-14-19
distribution         Debian GNU/Linux 9 \n \l
automount            no
USB devices          sda
datadir              /data/nextcloud/data
data in SD           no
data filesystem      ext2/ext3
data disk usage      491M/3.6T
rootfs usage         6.1G/15G
swapfile             none
dbdir                /data/database
Nextcloud check      ok
Nextcloud version    15.0.5.3
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       no
port check 80        closed
port check 443       closed
IP                   172.17.0.2
gateway              172.17.0.1
interface            eth0
certificates         none
NAT loopback         no
uptime               22min

I don’t know how the ports can’t be open.

So and when I get on the IP in the browser I just can see:

Initializing NextCloudPi for the first time
Please wait…

When I want to use ncp-update I get the error:

fatal: unable to access
https://github.com/nextcloud/nextcloudpi.git/’:
Could not resolve host: github.com
No internet connectivity

but I can ping GitHub without problems…

I also should mention that I try to install it on a mounted RAID system in a self created folder with

mkdir /media/storage/data

and the filesystem is EXT4.

Forgot to say to most important thing. I know there is already a solution for that but this solution does not work for me. I’ve done this procedure more than 10 times. I deleted the container, the volume and even the image but it does not help.

Anybody with an idea? I really have no ideas anymore. No solution…

That image works fine for me on -x86. Does : docker run hello-world
work okay? If not;
Only thing I can think of is try installing docker-ce
Works well for debian based systems…
Otherwise you could try the NCP image for Odroid
Or do you have a firewall blocking the ports?

No it was a bug with my router. I got a FritzBox maybe if someone will ever have the same problem. I was running NCP before on a static IP on a RPI3. Somehow there is a bug or something not compatible anymore like I read in some forums. I needed much time to figure out what the problem was. First of all only my docker container had no internet connectivity shown by system info or ncp-info. I was able to fix that with some changes in the docker config file with nano /etc/docker/daemon.json but that neither worked. From this point on I could ping e.g. Google in my container but still this bug.

The important command for me was: systemd-resolve --status which at least works in Ubuntu.
From that point on I could see that:

Link 2 (eth0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: {{ private MAC }}
                      192.168.178.29
          DNS Domain: fritz.box

This IP 192.168.178.29 was the old one of my RPI3 even though I deleted it completly in my router from every setting, every device that was ever there. I’ve restarted but the DNS Server was just stuck at this IP without any reason (bug). So I changed the IP of my new ODROID device to the old one of the RPI3 and then it worked instantly. Of course I deleted the container and volume again first.