Odroid HC4 NCP support thread

Sharing image shortly for testing

1 Like

Images uploaded for testing


Hi Nachoparker, found this thread and decided to buy a HC4 and give it a try. Slided a new spinning HDD in the toaster. Image boots, so far so good. I just encountered the problem that I cannot format the HDD using nc-format-USB:

ERROR: counted 0 devices. Please, only plug in the USB drive you want to format.

Is it possible that the HC4 doesn’t use USB for connection to the HDD?

I’ll try a spare HDD tomorrow and see if it makes any difference.

Will recieve my HC4 hardware next week and looking forward for testing.
Are there any known limitations or restrictations yet?
Is it possible to get the face recognition app running? I wasn’t able to run it on my HC1, so I’ll report the result.

An update on my side:

I installed Armbian and installed openmediavault successfully on a spare SD. Using the openmediavault UI, I formatted my new harddisk with the BTRFS filesystem. Everything seems fine using openmediavault. it lists my disk using fdisk -l.

Then got back to the Nextcloudpi image. Even with a formatted disk, it still does not detect my harddisk. I cannot mount it, I cannot (re)format it using the NCP wizard.
Using this image I cannot find my harddrive with:

fdisk -l

I just lists the SD-card and zram0 and zram1 disk

ls -l /dev/disk/by-uuid/

only lists …/…/mmcblk1p1 which is my SD-card.

I’m just a user… so stuck at the moment.

Maybe edit /etc/fstab to get it mount my hdd?

Wrote the HC4 Image to three different SD cards and i’ll always get stuck in Petitboot (dev.20201005), Nexcloud is not loading properly. Any ideas on this?

uhm I received feedback that it works, maybe you have a newer revision?

@svenjacobi If you don’t see the HDD try updating the kernel, maybe it’s buggy for your rev.

You always have the option of installing through softy on the latest Armbian image if that works for you.

Is your image for SD-Card or for 3,5"HDD?
I’ve now updated Petitboot as it is recommended by the Hardknernel forum, but still no booting via SD-Card into the Nextcloudpi image.

Don’t know how the installation via Softy works, any recommendations on that?

install armbian > go to softy > select nextcloudpi

I had to delete Petiteboot from the HC4 onboard flash memory. See therefore this post at the official Odroid forum.


Now the HC4 boots directly into the Nextcloud Image and have the same Issue as @svenjacobi, none of my hdd drive at the SATA ports are detected.

I did run
apt update
apt upgrade

My SATA drives don’t show up with lsblk or fdisk.

Did you map them within Nextcloudpi from ncp-config? By default it is simply reading from the sd card you flashed with the image.

Yes, i’ve tried ncp-config, but does not show my drives.
Had a test run with official Ubuntu image from Hardkernel and the drives are available with parted.

What I do is mount the drives via fstab. Cheers.

The provided Nextcloudpi image does not work with my HC4 and does not connect to any of my tested SATA drives.

I’ve tested the official Ubuntu from Hardkernel which worked fine. Yesterday I’ve made a Nextcloudpi installation, based on Armbian Buster 5.9y, my SATA drives show up and mounted them.

If Nextcloud provides a image for HC4 it should work out of the box, what at the moment is not given. You should also clarify the parameters for usage of the image, e.g. delete Petitboot, image for SD or SATA drive etc…

Not possible on my HC4 with the provided NCO image.

may this gets anyone further:
kernel on ambian (detecting SATA drives): kernel 5.9.14-meson64
kernel on nextcloudpi image (not detecting SATA drives): kernel 4.9.247

trying to change kernel in NCP image by using armbian-config to kernel-5.8.14-menson64 results in non bootable system

both NextCloudPi_odroidC4_12-12-20.tar.bz2 and NextCloudPi_odroidHC4_12-12-20.tar.bz2 boot odroidHC4 after removing petitboot, but non of them makes sata drives usable
(I think I’ve read somewhere, that HC4 is called HC4 not HC3 because it’s based on C4 - so I’d expect all C4 images to be usable on HC4 -> did the C4 have a sata port and was it usable with ncp image?)

I solved it by not using the privedes images. I’ve downloaded the Armbian Buster 5.9 image and installed Nextcloud via armbian-config as software. Had to manually mount the SATA drives and upgrade PHP to 7.4. Now it works on my HC4.

thanks for the info. Probably the Armbian code I used to build this image wasn’t all that mature. I am sure that the next image will contain all those fixes from them, including the right kernel. This is a pretty new board after all.


is there anything we can do to help?
can we build an updated image ourselves?