OCR working correct?

Hello community,

i am not getting the OCR working. I can click on jpg and command the scanning, but I can’t choose the option at pdf-files. Can anyone help me?

My Nextcloud is on the latest stable version and I am running a raspy 4 4GB.

Thanks for the help and sorry for my English,


Any one?

Problem still exist even after deinstallation and reinstallation the App.


Actually this is intended behavior. More details: https://github.com/janis91/ocr/issues/270


Thanks for the hint. I read the entries and read about an v5!?! How can I test this?

You can always try to download the “ocr.tar.gz” archive (not the source code from github) from https://apps.nextcloud.com/apps/ocr/releases and install an older app release manually.

I did figure out, how to install it. I am an beginner in these things.

After copying the files, nextcloud ist forcing me to update my apps (including ocr) and there ist no Dismiss or else.

After i installed the forced update, it still isn’t working…

Is there any possibility to get the ocr back to work on PDFs. Or any alternative? It was such a good thing.

I tried to use your app OCR and it is not working.
I use NC 18 and install the last version of OCR.
I also tried oldes versions and I still have a problem to load the language.
The console log display this messages :

  • tesseract-core.wasm.js:8 Please make sure the TESSDATA_PREFIX environment variable is set to your “tessdata” directory.
  • Tesseract couldn’t load any languages!
    Do you have any ideas how to fix it?