OCR App - conversion does not work after install & docker image does not start after reboot

Hi all,

I need some help with the OCR. Hopefully someone has an idea what I have done wrong.

Environment

I followed the documentation for installation with Docker @janis91 posted:

But after configuration within the admin part of the app I am not able to successfully convert documents. I created simple test files and tried to convert them. After starting the OCR process I just see a message that the document is added to the queue but then nothing happens.

After a reboot of my PI I now have the issue that the docker images are not starting any more. How can I enable them for an automatic start? with “sudo docker ps” I do not see them running.

If I try to start manual with the command from the documentation above I get an error.

Start command I tried:

sudo docker run --name redis --network=isolated_ocr -p 6379:6379 -d osmc/redis

Error I now get:

docker: Error response from daemon: Conflict. The container name “/redis” is already in use by container “0bc3cbffc71abae8e9819f41e2b2d3158c1e5904a6d8ca7ab964099d7e57cd4a”. You have to remove (or rename) that container to be able to reuse that name.
See ‘docker run --help’.

Questions:

  • Is there any logfile or overview of the queue where I can see a proper status?
  • Can I somehow manually test the docker images via the command line by converting a sample document?
  • Is it required to install “OCRmyPDF” and “tesseract-ocr” also on the main OS? I have not done it as I think that the software packages will only be required within the docker containers, correct?
  • Automatic re-start procedure for the docker images in case of system reboot?

I really hope that someone has ideas for me. I really like to get OCR working.

Thanks a lot for any hint.
Tombar

You need to remove it first

docker ps -a

docker stop XXXXXXXXXXXX
docker rm XXXXXXXXXXXX

and then run the build command again.

No, everything is within the docker container