ocDownloader - Returned GID is null ! Is Aria2c running as a daemon

I know that this problem have been there already several times. I did everything that was to do from the manual. But still I get the error “Returned GID is null ! Is Aria2c running as a daemon”

I use NextCloudPi in a docker container. Does it maybe not work because of this? I don’t know why it does not work. The YouTube Downloader does also not work. It’s installed but i get the error:

“Unable to retrieve true YouTube video URL”

I am on Ubuntu 18.04.2 LTS and NextCloud 16.0.3 but in NextCloudPi !

I have this problem also, since updating to 16.0.4

I have a script to setup ocDownloader after each Nextcloud Docker upgrade, and it worked until then. Now, even if I try to polish the aria2c command line parameters, I still get the “GID null” error.

Is this an issue with Nextcloud 16 ? There’s no complaint I can find about that on the github repo issues page.

I couldn’t get this running at any time. From where you got this script or what is to do? It would be very nice if you could share your knowledge.

With CURL the downloads get inserted but just refresh every second and are stuck on the status “waiting”.

I made my script after this how to : https://github.com/e-alfred/ocdownloader#aria2-installation

It worked until recently, don’t know if it’s since 16 or 16.x … Nobody to answer that …

Hmm then it’s maybe since 16 because I’ve started my system with 16 and docker and it never worked. But I thought that it’s my fault. The script I tried like 20 times… if the downloader would work, it would be such an amazing feature. I mean the cloud/server is running all the time anyway and you can store the downloads there if you download big files.

@sandy.locke were you successfull now or did you open an issue on GitHub?

I opened an issue on Github since it still doesn’t work after hours of trying. But nobody answer there.

@CptDayDreamer The issue seems to come from docker containers themselves. People running nextcloud without Docker do not seem to have this issue. So I’d tend to nail down the issue to some port forwarding issue, or some package missing from the container. Still trying to find a solution but ocdownloader’s maintainer help or a docker specialist’s help would be welcome …

EDIT: Also, Aria seems to be running in background as expected :

ps aux | grep aria2c

www-data    43  0.0  0.0  60800 10228 ?        Ss   13:21   0:00 aria2c --enable-rpc --rpc-allow-origin-all -c -D --log=/var/log/aria2c/aria2c.log --check-certificate=false --save-session=/var/local/aria2c/aria2c.sess --save-session-interval=2 --continue=true --input-file=/var/local/aria2c/aria2c.sess --rpc-save-upload-metadata=true --force-save=true --log-level=warn
root      1073  0.0  0.0   3084   892 pts/1    S+   13:42   0:00 grep aria2c

@sandy.locke yes that is what I also thought and detected. Aria runs, but it’s like the NextCloud container can’t access aria2c. Maybe Docker-compose im recommended but I hope it’s not because I’m not familiar with this at the moment.

apt install daemon
apt install rpcbind
apt install aria2
aria2c --daemon --enable-rpc=true

After a reboot you need to start aria2c yourself.
Aria2c has no build-in service you can create on yourself

Also best to run it as your webuser

I start aria2c like so

sudo -u www-data aria2c --enable-rpc --rpc-allow-origin-all -c -D --check-certificate=false --log=/var/log/aria2c.log --log-level=warn --dht-file-path=/etc/aria2/dht.dat --save-session=/etc/aria2/aria2.session --save-session-interval=2 --input-file=/etc/aria2/aria2.session --rpc-save-upload-metadata=true --force-save=true

I did all the steps above and still can’t download files. The site keeps asking “does aria2c act as a daemon”
Any ideas?

Just notes, for those who runs NC from manual installation (not docker), this solved my issue after ran this command. I am using NC23 php74.