OCC and fulltextsearch - reindexing particular files after error


#1

Dear all,

During indexing, various files are failed to be indexed because elasticsearch is crashed due to unknown reasons [No alive nodes found in your cluster].

Is there any method to re-index that particular failed file ?

Meanwhile, I shall be grateful if someone could point me to documentation of the syntax of “occ fulltextsearch” so that I could help myself. It seems that it’s not in the Admin Manual.

Thanks

Alex


#2

Hi,

I’d suggest, that read head over to the actual web site of the fulltextsearch project on github and read the wiki. There is a command reference there, which will help you to at least only have to re-index the actual user account, where this happened. Also, indexing first perform a compare to the current index to find out which files still need indexing.

However, what I never had, was elastic search crashing on me - very strange…


#3

Dear Budy,

I am not sure but…

I install elasticsearch container under docker, and after tuning the value of ES_JAVA_OPTS=-Xms512m -Xmx512m" (this is default setting) , it helps. Also, have you change the system config of : vm.max_map_count=262144 ?

Please see:
https://www.elastic.co/guide/en/elasticsearch/reference/current/docker.html

I will look into the configuration of elasticsearch later, after my system is up and running.

Alex


#4

Hi @alexkcy,

I am not using elasticsearch with docker - I installed it right onto a dedicated VM. However, I changed -Xms/-Xmx to 4G. vm.max_map_count has not been altered.


#5

Dear Budy,

Please let all us know if the situation is better after altering vm.max_map_count. Thanks !

Alex


#6

I don’t understand… elasticsearch is running just fine for me. I am using it on two NC instances, one of which is a 1200+ user one, and it is running rock solid.


#7

OH, I mis-read your message “However, what I never had, was elastic search crashing on me - very strange…”. I thought you said you experienced crashing.

I found out that ES crashes in my environment is because running out of RAM (I am greedy to do several tesseract jobs at the same time)

Alex


#8

Great. Running several index-jobs concurrently, had also been on my agenda… but I do run ES on another host anyway, so that wouldn’t bother it.