Notification text "[object Object]"

Nextcloud version: 12.0.0
Operating system and version: unknown, managed webhost
Apache or nginx version: unknown, managed webhost
PHP version: 7.0.22
Is this the first time you’ve seen this error?: yes (not sure when it started…)

Can you reliably replicate it?:
Yes, the error appears on every page load/reload within nextcloud.

The issue you are facing:
On the top-center position, messages and notifications are shown. Usually a text, followed by an “x” to close the message overlay. Right now, there is a Message containing “[object Object]” everytime i load or reload a page - any page - in nextcloud.

The output of your Nextcloud log in Admin > Logging:
Some old errors, nothing currently logged: The last ones:

Fatal	webdav	Sabre\DAV\Exception\MethodNotAllowed: HTTP/1.1 405 The resource you tried to create already exists	2017-07-31T14:03:33+0200

Error	PHP	Allowed memory size of 100663296 bytes exhausted (tried to allocate 20480 bytes) at /usr/www/users/[...]/lib/private/legacy/image.php#566	2017-07-19T10:20:48+0200

Error	PHP	Allowed memory size of 100663296 bytes exhausted (tried to allocate 8192 bytes) at /usr/www/users/[...]/lib/private/legacy/image.php#886	2017-07-19T10:20:48+0200

Error	gallery	Exception: Unspecified share exception (404)	2017-07-16T20:17:28+0200

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
No config file there, config.php is located in subdir “config/”:

$CONFIG = array (
  'instanceid' => '...',
  'passwordsalt' => '...',
  'secret' => '...',
  'trusted_domains' => 
  array (
    0 => '...',
  'datadirectory' => '/usr/www/users/[...]/data',
  'overwrite.cli.url' => '...',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'cloud_database',
  'dbhost' => '...',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '...',
  'dbpassword' => '...',
  'installed' => true,
  'mail_from_address' => 'mail',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_domain' => '...',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '...',
  'mail_smtpport' => '587',
  'mail_smtpsecure' => 'tls',
  'mail_smtpname' => '...',
  'mail_smtppassword' => '...',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:
Running Nextcloud on a managed webhost, i don’t have access to this log.

-> How to get rid of this annoying message? What Notification is this, how can i fix it?


Whatever caused the problem, after upgrading to version 12.0.1 (using the web-update-app), the message “[object Object]” disappeared.

That solved the problem :slight_smile:

1 Like

I had this “[object Object]” notification version 12.0.0 . I upgraded.
Now , version 12.0.2 for few weeks, this notification appears again for 4 days … what’s wrong ?
i’ll upgraded v 12.0.3 tomorrow , i’ll let you know if it disapears
Strange that notification that appears “sometimes” …

I answer to myself … i did the upgrade to 12.0.3 this morning and the notification disapears

DOn’t know what happened

I get this notification each time the Updater finds a new version. I know from other installations that this is the place where the update hint is shown.

I hope a developer finds the cause and fixes it in the next release.

SAme for me, but a change : I saw once that upgrade is available, then this “object” notification

Sorry if I’m late but I can reproduce the same behavior in Nextcloud 19.0.13 when visiting the homepage from logged-in. I have nothing in the application logs or in the webserver logs.