Notes android app not connecting to server

Hi everyone,

I’m having issues with the Notes mobile app not connecting to the server. I’m getting the error message “Invalid Login: Server connection broken”.

The Nextcloud mobile app is working fine, and I’m successfully syncing Contacts and Calendar. I can bring up the page in a browser no problem.

The fact that the error specifies that the connection is “broken” makes me wonder if it’s a TLS issue. My server is configured to support only TLS 1.2. Does the app only support TLS 1.0 or 1.1? I’m not really keen on weakening TLS security if I can help it (especially with TLS 1.3 on the way).

Is it possible the Notes app doesn’t recognise Let’s Encrypt certificates? K-9 Mail claims they’re invalid, but allows me to accept and continue. Maybe Notes is the same, but doesn’t allow me to continue?

Before upgrading to Nextcloud, I had ownNote working fine on ownCloud. Since there’s no official support for the ownNote app on Nextcloud, has anybody tried getting ownNote working on Nextcloud? I really miss having Notes! It’s the only drawback I’ve had to upgrading from ownCloud.

I’m using the latest Notes app (0.11.0) from F-Droid on Cyanogenmod 11 (Android 4.4), and Nextcloud 12.02 on FreeBSD 11.1 with PHP 5.6, and using Apache 2.4.27 and a Let’s Encrypt certificate.

I hope someone can come up with ideas or suggestions! Thanks in advance :slight_smile:


I had the same issue and the solution for me was just to import (CAdroid) the certificate on my device.

Best regards

Ah, so it’s that Notes doesn’t recognise the cert, not my server config. That’s good!

I just tried importing the cert as you recommended, but CAdroid says “The certificate chain is already trusted. You don’t need to import a certificate.” It won’t let me import it. I’ll have to find another way to import.

Damn. Since K-9 Mail complains every time I renew my Let’s Encrypt certificate (every two months), I guess I’ll need to do this relatively often.

Maybe I can find a way of getting ownNote working again…

Thanks anyway. You’ve narrowed down my problem and let me know it’s not my server, so you’ve helped and let me know I’ve not done anything stupid! (Which makes a nice change! :slight_smile: )

I had the same isseu with Notes on all my mobile devices (several tablets, smartphones).
You May try to remove your certificate (untrust it) and import again.


I can’t, since I didn’t import it in the first place.

It’s a valid CA cert I obtained through Let’s Encrypt, not self-signed. Up until this trouble with Notes, the only place it’s not been recognised is K-9 Mail.

I might try the Let’s Encrypt forum since it’s their certificate I’m having trouble with.

Ok, I just discovered the problem - Notes doesn’t work with TLS 1.2 - I had to downgrade security to TLS 1.0 and 1.1 and then it worked!

1 Like

Oh dear. Worth an issue I think since downgrading shouldn’t be considered a solution.

1 Like

No, it shouldn’t. I’ve gone back to only TLS 1.2, and will report the issue on … the Notes github page? I can’t think of anywhere more appropriate.

It took me longer to find the issue than it should have. I didn’t think the protocol could possibly be a problem in 2017. TLS 1.2 has been out a decade, but Notes can’t use it? I’m shocked!

Notes repo sounds right, and looks like you found it :).
Fully agree with you.

Your issue for anyone else finding this: