Not properly set up to resolve "/.well-known/caldav"

Running NC 17 on a shared hosting platform (so don’t have control of everything). Running on Apache/PHP 7.3. Everything is running fine and I want to start experimenting with synching my calendars on Android with DAVx5 etc so assume I have to have the caldav/carddav resolution set-up correctly

I get the common cannot resolve errors:

  • Your web server is not properly set up to resolve “/.well-known/caldav”. Further information can be found in the documentation.
  • Your web server is not properly set up to resolve “/.well-known/carddav”. Further information can be found in the documentation.

I’ve tried to follow the instructions (to the extent that I understand them) by adding the following in .htaccess . I run nextcloud in a subolder called nextcloud…

RewriteEngine on RewriteRule ^\.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L] RewriteRule ^\.well-known/host-meta\.json /nextcloud/public.php?service=host-meta-json [QSA,L] RewriteRule ^\.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L] RewriteRule ^\.well-known/carddav /nextcloud/remote.php/dav/ [R=301,L] RewriteRule ^\.well-known/caldav /nextcloud/remote.php/dav/ [R=301,L]

I suspect the problem may be the correct location to add/change these Rewriterules cos they don’t seem to get used. I’ve tried the .htaccess in the nextcloud subfolder but this doesn’t work.

Any suggestions?

I have the exact same issue (though still on NC 16.0.5). I put that file in various folders (/var/www/, /var/www/nextcloud, /var/www/html/) but it never helped with that error message.

Not a huge issue since the clients do find the calendars through the links.

Still it would be helpful if someone could point out what is wrong in our setup.

Thank you!

This doesn’t seem too complicated. Nobody has any ideas?

yes… one if it was: apparently you were searching the forum. but then why didnt you fin the solving links? as there are solutions here on the forum.

plus: they might be different for nc 16.x and nc 17.x

If we’d both found the ‘solving links’ then we wouldn’t be posting here would we? We’ve followed the installation instructions and cannot fix the problem which seems to indicate the instructions may not tell the whole story. I had the same problem with nc 16 before my current nc 17 install. This is the only problem I have with nc 17.

Perhaps if you have ideas on how to fix, you could point more specifically to the solution?

nc 16: /.well-known/caldav

nc 17: Nextcloud 17 false warnings

good luck…

… you might wanna use the search function of the forum next time :wink:

I’m after getting rid of the message suggesting to only use https I’ve encountered the above mentioned error. Didn’t have that one before. I’ve searched through the forum and read the documentation but I have already made those changes that are mentioned.

I’ve set the URL to the suggested path of

  RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]

RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]

but I am still getting a warning:

  • Your web server is not properly set up to resolve “/.well-known/caldav”. Further information can be found in the documentation.
  • Your web server is not properly set up to resolve “/.well-known/carddav”. Further information can be found in the documentation.

I’m at version 17. My Installpath is /docker/nextcloud/ I even tried that as well, but to no avail.

Can somebody help me out here? :slight_smile:

I’m sure JimmyKater will soon chime in and tell you to use the search function…

I, probably like you, have done multiple searches and found multiple potential solutions none of which work. I’m using shared hosting so don’t have control/access to all the config files. The obvious place and the one the install instructions point to is the nextcloud/.htaccess file but changes there don’t seem to have any effect.

While I’m not completely technically illiterate I’m not a technical enough to decipher some of these posts (especially when they are in German). The fact that this topic is so frequently discussed and there seem to be several people at any one time with this problem seems to point to it being something that needs to be better documented.


hey… i’m chiming in here to tell you that it’s always important to give out some more infos about your instance, setup and environment (if i’m not very much mistaken there even is a template provided when you’re entering an issue here - and it’s not there for fun) - if you want to have the chance of getting more detailed help.

like this one is a good info.

in this case it could be helpful to setup a batchfile where you’re trying to read your config file into some file that you are allowed to access… then do the changes that need to be done to it and then another batch to write it back. maybe even via a cron-job.

and never ever forget taking backups before fiddling around with things like that :wink:

good luck

What kind of batch file need be written ?