Non-Nextcloud created file deletion

I’m running Nextcloud 28.04.

I am able to delete files that Nextcloud has created but not ones that are existing on my external storage (and even then, it’s a mixed bag).

Permissions are set to 755 (www-data as owner) on both the folders and files but it doesn’t seem to make a difference. If I create a new file/upload via Nextcloud or even make a copy of a non-Nextcloud created file, it will be deletable and work just fine.

If I try to move an existing non-Nextcloud created file and/or try to delete it, it will fail (and won’t even have the option to delete).

Interestingly, files in some folders are deletable. Their permissions are identical to the others and I can’t figure out why there is a difference.

There are no logs regarding this. Not sure if it’ll help, but these files come from Google Takeout.

hey @ac2323 and welcome to the community-forum of NC

have you tried sudo -u www-data php occ files:scan --all on your bash (from your nextcloud installing-directory) to make all external files known to your NC?

This fixed it for me, thank you!

1 Like