No upload possible after backup restore of whole server

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.4
Operating system and version (eg, Ubuntu 20.04): Ubuntu
Apache or nginx version (eg, Apache 2.4.25): nginx
PHP version (eg, 7.4): 8.1.16

The issue you are facing:

I’m running nextcloud in a docker with mariadb / letsencrypt / nginx-reverseproxy
After a backuprestore of my server, i cant upload anything.
Since the restore was only 1 day old an had no changes to the config or anything else i don’t know what could have caused this.
What did i try?

  • filesystem check
  • repair
  • sync cache
  • docker down + docker compose with same config
  • update everything

Is this the first time you’ve seen this error? (Y):

Steps to replicate it:

  1. Upload file from anywhere (App/webinterface)
  2. Error

The output of your Nextcloud log in Admin > Logging:

[webdav] Debug: Sabre\DAV\Exception\NotFound: File with name PATH/TO/FILENAME could not be located at <<closure>>

 0. /var/www/html/3rdparty/sabre/dav/lib/DAV/Tree.php line 78
 1. /var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 76
 2. /var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    Sabre\DAV\CorePlugin->httpGet(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 3. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 472
    Sabre\DAV\Server->emit("method:GET", [["Sabre\\HTTP\\ ... ]])
 4. /var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 251
    Sabre\DAV\Server->invokeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"], false)
 5. /var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    Sabre\DAV\CorePlugin->httpHead(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 6. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 472
    Sabre\DAV\Server->emit("method:HEAD", [["Sabre\\HTTP\\ ... ]])
 7. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 253
    Sabre\DAV\Server->invokeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
 8. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 321
 9. /var/www/html/apps/dav/lib/Server.php line 360
10. /var/www/html/apps/dav/appinfo/v2/remote.php line 35
11. /var/www/html/remote.php line 171
    require_once("/var/www/html/a ... p")

HEAD /remote.php/dav/files/PATH/TO/FILENAME
from by USER at 2023-09-15T19:58:01+00:00
[webdav] Debug: Sabre\DAV\Exception\MethodNotAllowed: The resource you tried to create already exists at <<closure>>

0. /var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 560
   Sabre\DAV\Server->createCollection("uploads/USER/3e ... 3", ["Sabre\\DAV\\MkCol"])
1. /var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
   Sabre\DAV\CorePlugin->httpMkcol(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
2. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 472
   Sabre\DAV\Server->emit("method:MKCOL", [["Sabre\\HTTP\\ ... ]])
3. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 253
   Sabre\DAV\Server->invokeMethod(["Sabre\\HTTP\\Request"], ["Sabre\\HTTP\\Response"])
4. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 321
5. /var/www/html/apps/dav/lib/Server.php line 360
6. /var/www/html/apps/dav/appinfo/v2/remote.php line 35
7. /var/www/html/remote.php line 171
   require_once("/var/www/html/a ... p")

MKCOL /remote.php/dav/uploads/USER/LONGID
from by USER at 2023-09-15T19:58:01+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

    "htaccess.RewriteBase": "\/",
    "memcache.local": "\\OC\\Memcache\\APCu",
    "apps_paths": [
            "path": "\/var\/www\/html\/apps",
            "url": "\/apps",
            "writable": false
            "path": "\/var\/www\/html\/custom_apps",
            "url": "\/custom_apps",
            "writable": true
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "trusted_proxies": "***REMOVED SENSITIVE VALUE***",
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "DOMAINNAME",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "theme": "",
    "loglevel": 0,
    "maintenance": false,
    "mail_smtpmode": "smtp",
    "mail_smtpsecure": "tls",
    "mail_sendmailmode": "smtp",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpauth": 1,
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "587",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "has_rebuilt_cache": true,
    "upload_max_filesize": "2G",
    "post_max_size": "2G",
    "updater.secret": "***REMOVED SENSITIVE VALUE***"

The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.



Nextcloud dev for Android gave the error Message:
Invalide file size: File to big.
So i double checked for any filesize problems but found none.
Frustratingly somehow nextcloud for android uploaded
2 random pictures. I tried uploading a small .odt file
which worked. A pdf didn't

I got similar issue

When uploading some files using Android NextCloud App. I can upload files using web. Some files work fine. Removing extension .mp3 helps.

[webdav] Debug: Sabre\DAV\Exception\NotFound: File with name /audioRec/Hanuman.mp3 could not be located at <>

  1. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/Tree.php line 78
  2. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 76
  3. /home2/dobekp/public_html/nc/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    Sabre\DAV\CorePlugin->httpGet([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”])
  4. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/Server.php line 472
    Sabre\DAV\Server->emit(“method:GET”, [["Sabre\HTTP\ … ]])
  5. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 251
    Sabre\DAV\Server->invokeMethod([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”], false)
  6. /home2/dobekp/public_html/nc/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    Sabre\DAV\CorePlugin->httpHead([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”])
  7. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/Server.php line 472
    Sabre\DAV\Server->emit(“method:HEAD”, [["Sabre\HTTP\ … ]])
  8. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/Server.php line 253
    Sabre\DAV\Server->invokeMethod([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”])
  9. /home2/dobekp/public_html/nc/3rdparty/sabre/dav/lib/DAV/Server.php line 321
  10. /home2/dobekp/public_html/nc/apps/dav/lib/Server.php line 365
  11. /home2/dobekp/public_html/nc/apps/dav/appinfo/v2/remote.php line 35
  12. /home2/dobekp/public_html/nc/remote.php line 172
    require_once(“/home2/dobekp/p … p”)

HEAD /nc/remote.php/dav/files/dobek/audioRec/Hanuman.mp3
from by dobek at 2023-12-25T00:58:41+00:00