No Nextcloud icon in panel on Mint

I am having a minor problem having set up my sync clients using your information.

I have several machines all running the same (nominally) OS (Mint 18.1 Cinnamon). All but one of these machines do not show Nextcloud icons in the panel I have to re-open the client from the menu. The sync client appears to work without fault on all machines - the various client machines use different content from the server and are used for different purposes.

Any suggestions as to a fix for this problem would be appreciated. (The server is on a Raspberry Pi 3b running Raspbian and NC 11.0.2

Missing Nextcloud Sync icons in panel Mint 18.1 Cinnamon

Having given up trying to find a solution to the missing icon problem i posted my previous entry. Then immediately found a solution.

I found a forum posting (Owncloud 2014) suggesting that there needed to be delay placed in the startup apps list for the Nextcloud Client.

I added a 5 second start up delay and IT WORKS.

1 Like

same problem with Mint 18.1 Cinnamon…
… added 5 seconds for start up
=> it works :slight_smile: :slight_smile: :slight_smile:

Hi franc.marx

I’m running the sync client on 6 machines all running Mint 18.1 and Cinnamon - most worked with the 5 second delay one required 15 seconds.


Please give a hint how to add the delay. I have mint on my laptop sincd one day…
Too easy… found it…

Same issue on Ubuntu 16.04 Gnome Shell. Since last updates the tray icon disappeared but the client still run in the background.

Has this ever been fixed? I have this issue on three machines running Ubutnu 16.04, Gnome Shell 3.18.5, Nextcloud Client 2.3.1. The workaround above is not working. Anybody a hint?

I could solve this on two machines by adding


to autostart.

Maybe this helps anyone, too.

On the last machines I fixed it by removing appmenu-qt5

sudo apt-get remove appmenu-qt5

as discussed here

For me on Linux Mint Cinnamon the startdelay of 10 seconds works fine. Always have the icon…

With owncloud client I had prefaced with
this also seems to work with nextcloud client

This was also mentioned in the the link by @nin-0

No indicator icon her in ubuntu 20.10, any solution for that issue?

No icon Manjaro XFCE
I dont have autostart and so dont think a delay will help (I start it hours after OS startup sometimes)

I’ve same problem on several Ubuntu 20.4 LTS installations.

Workarroudn for me like for others in this thread.
Remove Auto Start of nextcloud in nextcloud settings.

I start nextcloud with timeout.

sh -c “sleep 20 ; nextcloud”