No mimetype icons in Firefox

I think this started in NC 14, but it could also be in FF 64:

No file or folder icons show in the files app. The Favourites overlay icons shows just fine - and in Chromium they also show.

The links to the background images are correct, and they can be viewed from the direct link.

I tried to remove appdata_<IID>/preview but to no avail, no icons were created in the folder.
I also ran:

occ files:cleanup
occ files:scan-app-data
occ preview:generate-all

Which gave me back thumbnails for at least images and text files, but not for .pdf, .odt etc. And not for folders.

<td class="filename ui-draggable">
  <a class="name" href="/index.php/apps/files?dir=//Documents">
    <div class="thumbnail-wrapper">
      <div class="thumbnail" style="background-image:url(/apps/theming/img/core/filetypes/folder.svg?v=1);">
        <div class="favorite-mark permanent">
          <span class="icon icon-starred"></span>
          <span class="hidden-visually">Favorited</span>
    <span class="nametext">
      <span class="innernametext">Documents</span>
    <span class="uploadtext" currentuploads="0"></span>
    <span class="fileactions">
      <a class="action action-share permanent" href="#" data-action="Share" data-original-title="" title="">
      <span class="icon icon-shared"></span>
      <span class="hidden-visually">Share</span>
    <a class="action action-menu permanent" href="#" data-action="menu" data-original-title="" title="">
    <span class="icon icon-more"></span>
    <span class="hidden-visually">Actions</span>


You could try the following:

  • run these occ commands:
    • maintenance:mimetype:update-db
    • maintenance:mimetype:update-js
  • clear browser cache
  • perform full reload via CTRL + F5
  • start browser without any plugins to check if any plugin is interfering

I didn’t/ don’t see any issues with NC14, NC15 now and FF64. Therefor I assume an issue with caching somewhere.
Are you using uOrigin plugin for Internet privacy? One user had an issue a little similar to yours and he had to disable (CSS) filtering for the Nextcloud site.
Good luck!

I would say so too, but it didn’t make a difference. I ran the occ commands, disabled all plugins - including Privacy Badger and DuckDuckGo privacy Essentials (I’m not using uOrigin) - cleared the cache, restarted FF and did a full refresh, but to no avail…

Thanks for the suggestions though :slight_smile:

There are a lot of these lines in the apache log:

[Mon Dec 17 18:06:01 2018] [error] [client] client denied by server configuration: /home/sites/site34/web/cloud/apps/theming/img/core

I’m on a shared hosting, hence the long path.

Is it maybe because they’re SVG files?

Generated thumbnails are shown just fine, e.g.

Although FF should support using SVG:

Can it really be true, that I’m the only one using Firefox and NC >= 14?

Firefox on Android doesn’t show icons either:

Maybe something went wrong during the update.
I didn’t see this issue on NC14 (I ran all NC14 versions) and I don’t see such issue on NC15.

Maybe a job during update didn’t run, or there is some small configuration issue.
Did you copy the web server config from the latest NC (in your case NC14) documentation?

For some config parts the order did matter. Here is a quote from my nginx config:

    # Adding the cache control header for js and css files
    # Make sure it is BELOW the PHP block
    location ~ \.(?:css|js|woff|svg|gif)$

Do you have PHP module imagick running? (Just asking)

I’m on a shared hosting provider so I don’t know about the config - apache btw. Not sure about ImageMagick either.

No imagick doesn’t seem to be loaded. Is it necessary?
GD imaging is loaded though.

I may have found the culprit. The issue is closed, though:

You need to added those file types in config to enable preview of them (

'enabledPreviewProviders' => array(

Only register providers that have been explicitly enabled

The following providers are disabled by default due to performance or privacy concerns:


Now you need to do small job:

  • Stop Webserver (apache / nginx)
    service apache2 stop

  • Run
    sudo -u www-data php /var/www/nextcloud/occ files:scan-app-data
    to fix database

  • Start Webserver and Test everything works
    service apache2 start

  • Generate previews by run command:
    sudo -u www-data php /var/www/nextcloud/occ preview:generate-all

Thanks, but that wasn’t the issue. It is the mime type icons that were missing. See the screen shots at github:

1 Like