No login via DDNS in Nextcloud app

Good morning,
I already tried a post in the german forum, but there was no response / no idea. Maybe someone here nows the solution…
Problem:
Nextcloud runs without any problems in Docker SWARM.
If I use the iPhone APP and I am logged in via LAN with the local IP, everything works.
If I try to log in externally via a DDNS, I get to the user input, should then “grant access” to my device, which I do, then it doesn’t go any further…
If I use a browser with the DDNS from outside, it works without any problems.

The two approaches here in the forum do not work for me either
docker exec -it -u www-data NAME_NEXTCLOUD_CONTAINER bash -c ‘./occ config:system:set overwriteprotocol --value=“https”’

Is the problem maybe cause because I am in SWARM mode?

I can’t find the error… One of you?

Thanks in advance.

Greetings Marc

Normally you do not need and should not use “local IP”. Search for internal access with external name (e.g. DDNS) Hairpinning and NAT Traversal. Then you can use your iPhone with the same Nextcloud name from your LAN and from Internet. Please solve this problem. Maybe it’s a little related to your problem.

For your problem.
1.) Please configure in your Nextcloud config/config.php all for your external name and nothing for your “local IP”. Perhaps you can temporary delete your “local IP” from this setting.
2.) Also you find in Nextcloud web access and then Settings → Security → Devices (Einstellungen → Persönlich → Sicherheit) your used devices. Delete all iPhone entrys and try it again.

If nothing helps please post logs from your Nextcloud.

Hi. thank you for your reply.

I edited the config.php but still the same…

i also tried to delete the devices under Settings → Security → Devices. Message here: marked for remote deletion

I got this error in the log:
Swift_TransportException: Expected response code 354 but got code “554”, with message "554 5.5.1 Error: no valid recipients
"