No Login possible - White Page

Nextcloud version: 13.0.1.1
Operating system: Synology Diskstation DSM 6.1.6-15266 Update 1
Apache Version:2.4.29
PHP Version: 7.0.28

I have successful installed the latest version 13.0.1.1 of Nextcloud. In the beginning I could log on to Nextcloud with a Webbrowser and everything worked as expected. But now when I try to open Nextcloud with a Webbrowser I get only a white screen.

In the Nextcloud log file I can see a ErrorExeption: Cannot modify header information… More details see last extract of nextcloud.log file:

The output of your Nextcloud log in Admin > Logging:

{"reqId":"U96qB9NKEnA8WqNNcC2u","level":3,"time":"2018-04-18T06:40:05+00:00","remoteAddr":"192.168.178.77","user":"--","app":"PHP","method":"GET","url":"\/nextcloud\/","message":"ErrorException: Cannot modify header information - headers already sent by (output started at \/volume1\/web\/nextcloud\/config\/config.php:1) at \/volume1\/web\/nextcloud\/lib\/private\/Session\/Internal.php#151","userAgent":"Mozilla\/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit\/605.1.15 (KHTML, like Gecko) Version\/11.1 Safari\/605.1.15","version":"13.0.1.1"}

The output of my config.php file:

<?php
$CONFIG = array (
  'instanceid' => '<instanceid>',
  'passwordsalt' => 'passwordsalt',
  'secret' => 'superlongstring',
  'trusted_domains' =>
  array (
    0 => 'mynas.fritz.box',
    1 => 'mynas',
    2 => 'cloud.mydomain.com',
  ),
  'datadirectory' => '/volume1/NextCloud',
  'overwrite.cli.url' => 'https://mynas.fritz.box/nextcloud',
  'dbtype' => 'mysql',
  'version' => '13.0.1.1',
  'dbname' => 'NextCloud',
  'dbhost' => '127.0.0.1:3307',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_<dbuser>',
  'dbpassword' => '<dbpassword>',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
);

How can I repair this?

Could be this here:

Changes in Nextcloud 13

A detailed log of all changes can be found in the official Changelog. There are also all current and previous versions linked.

Updates to Nginx configuration

  • In the Nginx configuration the Same-Origin header was removed. This is now handled in PHP and keeping it will result in a wrong header. Please remove those lines in your Nginx config: add_header X-Frame-Options "SAMEORIGIN"; See Nginx configuration

https://docs.nextcloud.com/server/13/admin_manual/release_notes.html

Hello Schmu,

thanks for your reply but I cannot find such a line in the nginx config of Synology Diskstation.
The error message reports that it cannot modify header information. The message is not the header information is wrong.

Well, the full message is:

And this is exactly what is written in the admin guide, the config line should be removed so that the header isn’t sent twice :wink:
My big mistake here however is, that you use Apache and I didn’t see that at first. So while my linked documentation refers to nginx, this is wrong and doesn’t help here.

Nonetheless, we should still check where the header is sent twice then. As far as I know headers for apache can be set in .htaccess and probably in the apache config.

Edit: Can you run the test here


And check the output for your headers? Maybe you can post them here.

1 Like

I am calling nextcloud from an internal network with http://192.168.178.99/nextcloud and get the error message.

Hello Schmu,

thank you for your help.
I could solve it. I made a mistake when I edited the Nextcloud config.php file. Before the first line with <?php I had an empty line which caused the error message.