No login possible on odroid-installation [solved]

ncp
odroid

#1

I downloaded the last version of Nextcloud for Odroid, wrote it to sd-card, made a “touch ssh” in the root-folder and started the machine with it. I get into the web-interface and can work there. SSH is not enabled and if I try to enable it, I get the message, that root has the standart-password and that’s a security-issue and therefore SSH will not be enabled.

Login to the machine direct via keyboard and monitor: with pi and raspberry I get incorrect login. Login with ncp and his password works - I get the login-berry-image, but that ends immediately with a logout.

What can I do?

Spielmops

Found it myself:
login user: root, password: 1234


#2

nachoparker wrote:

please, read the wiki for a guide.

in odroid there is no pi user. you have to do root and then a new password that is not the default 1234

you can activate SSH through ncp-web

cheers!

What I did before I even bought an Odroid-computer: I read the wiki and tried the first install on my Raspberry Pi. And I read it anew, when I had the NC-image on the Odroid running. And when I could not login to the console, I read the wiki for the third time. I’m very sorry, but I did not find the information about how to login to the Odroid-OS. Please point me to that paragraph.

And by the way: I can not find any information regarding “raspi-config” in the wiki. I need that to configure my language and keyboard.

What I did read, when I gathered information about Nextcloud: “Easy to set up for non technical users”. My knowledge about Debian levels near zero, but with distributions I work already for a while (about 19 years). So I should have no difficulties …

Spielmops


#3

It is not part of NCP but of Raspbian


#4

Spielmops does not believe this …


#5

Hello,

This is a collaborative effort to help people. Please feel free and encouraged to add to the wiki anything that you find missing. That is how everything you see there ever happened!

cheers


#6

Ok, I will. But I need one information: how to enable ssh without monitor and keyboard connected to the Odroid-device?


#7

On Pi you can add empty file called ssh in /boot to enable ssh
Dont have an Odroid, so dont know if it will work for you
On my Linux machine I mount the sdcard
and create the file in the first vfat partition, which gets mounted as /boot.


#8

If you have no experience with the Odroid-Nextcloud-image, then why to you tell me anything about it? Read my post and you will see, that I read the installation-guide several times …


#9

@Spielmops
If you do solve this and manage to enable ssh on Odroid without screen or keyboard attached.
Please share it here or create a wiki page so others can profit from your experience. As suggested by

Thank you for your time and efforts.


#10

Didn’t you read this?

I can not solve this question, because I have only one Odroid-device and that is already working as a server. So no going back to start …

By the way: the Odroid XU4 with a SSD on USB3 is about 20 times faster than a Raspberry Pi 3B with a very fast SD-card.


#11

SSH is disabled by default for security reasons. You can enable it from ncp-web, SSH section.

Cheers


#12

… and I have to login as root. If I try to start ssh, I get the message: No! not as root! Securitty reason …


#13

the exact message is not that you can’t use root, it’s

The user root is using the default password. Refusing to activate SSH

Just change the default password