No invitation email sent -> Swift_TransportException

Nextcloud version: 16.0.3 with official docker container
OS and version: QNAP QTS
PHP version: 7.3.8

Is this the first time you’ve seen this error?: No. Happens everytime i try to invite someone.

The output of your Nextcloud log in Admin > Logging:

[dav] Error: Swift_TransportException: Expected response code 250 but got code "550", with message "550 Request failed; Mailbox unavailable
" at <<closure>>

 0. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 341
    Swift_Transport_AbstractSmtpTransport->assertResponseCode("550 Request fai ... n", [250])
 1. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php line 305
    Swift_Transport_AbstractSmtpTransport->executeCommand("\r\n.\r\n", [250], [], false, null)
 2. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 404
    Swift_Transport_EsmtpTransport->executeCommand("\r\n.\r\n", [250])
 3. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 500
    Swift_Transport_AbstractSmtpTransport->streamMessage(Swift_Message {})
 4. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 516
    Swift_Transport_AbstractSmtpTransport->doMailTransaction(Swift_Message {}, "<sender mail>", ["recipients mail>"], [])
 5. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 206
    Swift_Transport_AbstractSmtpTransport->sendTo(Swift_Message {}, "<sender mail>", {"<recipients mail>"}, [])
 6. /var/www/html/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Mailer.php line 71
    Swift_Transport_AbstractSmtpTransport->send(Swift_Message {}, [])
 7. /var/www/html/lib/private/Mail/Mailer.php line 180
    Swift_Mailer->send(Swift_Message {}, [])
 8. /var/www/html/apps/dav/lib/CalDAV/Schedule/IMipPlugin.php line 255
    OC\Mail\Mailer->send(OC\Mail\Message {})
 9. <<closure>>
    OCA\DAV\CalDAV\Schedule\IMipPlugin->schedule(Sabre\VObject\IT ... e})
10. /var/www/html/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    undefinedundefinedcall_user_func_array([OCA\DAV\CalDAV\ ... "], [Sabre\VObject\I ... }])
11. /var/www/html/3rdparty/sabre/dav/lib/CalDAV/Schedule/Plugin.php line 384
    Sabre\Event\EventEmitter->emit("schedule", [Sabre\VObject\I ... }])
12. /var/www/html/3rdparty/sabre/dav/lib/CalDAV/Schedule/Plugin.php line 665
    Sabre\CalDAV\Schedule\Plugin->deliver(Sabre\VObject\IT ... e})
13. /var/www/html/apps/dav/lib/CalDAV/Schedule/Plugin.php line 180
    Sabre\CalDAV\Schedule\Plugin->processICalendarChange(null, Sabre\VObject\Co ... l}, ["mailto:<recipients mail> "], [], true)
14. <<closure>>
    OCA\DAV\CalDAV\Schedule\Plugin->calendarObjectChange(Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {}, Sabre\VObject\Co ... l}, "calendars/Stephan/personal", true, true)
15. /var/www/html/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    undefinedundefinedcall_user_func_array([OCA\DAV\CalDAV\ ... "], [Sabre\HTTP\Requ ... e])
16. /var/www/html/3rdparty/sabre/dav/lib/CalDAV/Plugin.php line 943
    Sabre\Event\EventEmitter->emit("calendarObjectChange", [Sabre\HTTP\Requ ... e])
17. /var/www/html/3rdparty/sabre/dav/lib/CalDAV/Plugin.php line 801
    Sabre\CalDAV\Plugin->validateICalendar("BEGIN:VCALENDAR ... R", "calendars/Steph ... s", false, Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {}, true)
18. <<closure>>
    Sabre\CalDAV\Plugin->beforeCreateFile("calendars/Steph ... s", "BEGIN:VCALENDAR ... R", OCA\DAV\CalDAV\Calendar {}, false)
19. /var/www/html/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    undefinedundefinedcall_user_func_array([OCA\DAV\CalDAV\ ... "], ["calendars/Step ... e])
20. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 1094
    Sabre\Event\EventEmitter->emit("beforeCreateFile", ["calendars/Step ... e])
21. /var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 525
    Sabre\DAV\Server->createFile("calendars/Steph ... s", "BEGIN:VCALENDAR ... R", null)
22. <<closure>>
    Sabre\DAV\CorePlugin->httpPut(Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {})
23. /var/www/html/3rdparty/sabre/event/lib/EventEmitterTrait.php line 105
    undefinedundefinedcall_user_func_array([Sabre\DAV\CorePlugin {},"httpPut"], [Sabre\HTTP\Requ ... }])
24. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 479
    Sabre\Event\EventEmitter->emit("method:PUT", [Sabre\HTTP\Requ ... }])
25. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 254
    Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Reque ... "}, Sabre\HTTP\Response {})
26. /var/www/html/apps/dav/lib/Server.php line 316
    Sabre\DAV\Server->exec()
27. /var/www/html/apps/dav/appinfo/v2/remote.php line 35
    OCA\DAV\Server->exec()
28. /var/www/html/remote.php line 163
    undefinedundefinedrequire_once("/var/www/html/a ... p")

PUT /nxtcld/remote.php/dav/calendars/Stephan/personal/Nextcloud-ABCDEFGHIJKLMNOPQRSTUVWXYZ.ics
from 111.222.333.444 by Stephan at 2019-08-22T14:12:12+00:00

Hi everyone,

i’m running nextcloud for about 3 months (so i’m quiet new to it) and i’m facing some problems using calendar invitations:
if i try to invite someone i get Swift_TransportException and no e-mail invitation is send.
E-Mail itself is configured right (test mail is send correctly) and i get notification of changes like i configured.
But invitation does not work. Can someone please hel me.

Thanks

Information:

  • i’m running NC as docker container on my QNAP
  • i’m using yahoo to send mails (no own mail server)
  • sending invitations is enabled in groupware

Hi balli1187

the error message states 550 Request failed; Mailbox unavailable which looks like a bounce of the mailserver, as the server could not find the mailbox of the recipient.

Are you sure that the email address of the recipient exists?

Dear Felix,

i tried with 4 different mail adresses with one being my work account that works absolutly fine. I didn’t get invitation send to of those adresses.
Normally i set up a new calender entry on my iPhone so i have mail adresses in my adressbook and checked. I also tried it from NC web interface to make sure its not an iPhone problem with same result.

Are you sure that “Mailbox unavailable” refers to recipient’s mailbox? I thought its the outgoing mailbox (sender’s mailbox).

Regards, Stephan

I am pretty sure that the message 550 Request failed; Mailbox unavailable is the response from the remote/destination server.

I tried the calendar app now on my DEV playground and successfully sent an invitation and received it as well. I did notice though, that the sent email had a “Reply-To” Header in it. Some providers don’t like these and block these in their mail servers. In that case the mail server only sends the response 550 Request failed; Mailbox unavailable which is quite vague.

Could you try and send an email straight from your mail server to the recipients and see if they get your mails? If that’s the case, there needs to be a solution to remove the “Reply-To” Header from the mails of NC.

I tried to send a test mail from my NC mail account (yahoo) to 2 of the adresses i wanted to invite and it got it there straight ahead.

Your explanations sounds reasonable… What kind of provider have you tested? Maybe we can recreate the problem?
I also tried to invite a contact with gmail.com adress. thought its widely used and problem must has been recognized before.
Was this header added in the last updates? i just found out, that it worked in May when i started playing around with nextcloud :confused:

I sent the invitation from my private DEV playground (my own mail server) to a gmail hosted email address and it got there without a problem. I also tried to reset my password, to see if it’s NC or the Calendar App adding this header.

The password reset mail did not have that header, so I guess it’s the app adding this header.

So did I get that right, you are using your Yahoo account as the Email server? Were you using this exact mail server in May, when the sending of mails was working?

It could well be, that the problem is being caused by a misconfiguration due to playing around with the configuration?! But that’s hard to analyze, if we don’t know what has been changed.

yes, right. I configured the my existing yahoo-Mail account in nextcloud like shown here https://docs.nextcloud.com/server/14/admin_manual/configuration_server/email_configuration.html

As other mails, like notification of changed files or even changed or added appointments in a shared calender, are send correctly i think configuration is okay. neverthelesse i tried different configuration SSL/TLS or STARTTLS with ports 25, 465 or 587.
Of course not every combination was working. But i got confimation mail with more than one config but invitations didn’t work in any case.

Hi balli,

I thought about this again but could not really come up with a proper solution. The facts:

  • Test Email via “Settings -> Basic settings -> Email server” works
  • Notification mails from Nextcloud are working fine

Just to do some more testing, do you have a Gmail account you could use for your “Email server” settings? It would be interesting to see, if that happens with another email provider, other than Yahoo, as well.

Dear Felix,

i tried another mail provider and got it working with web.de :crazy_face:
I first tried gmail but ran into security issues. But more importantly it seems to be a provider relatet problem… I’m confused as it worked in may also with yahoo. Maybe yahoo made some changes?

anyway… i would prefer to use the yahoo adress as i set it up just for this case. if you have any idea how to go on with this issue, i would likely test further things.

Hey balli,

I’m glad to hear that it does in fact work with another email provider. So Yahoo must have done some changes to their service, which is not preventing you to send invitation mails.

This is just me guessing, but it could well be the “Reply to” header, since normal notification mails from NC do not contain this header but the calendar app does. Maybe Yahoo is not happy with this one and rejects the mail straight away upon sending.

Unfortunately there is not much you can do in the settings, so my best guess is to address this issue at the Nextcloud Calendar Github website. Unless someone else has another idea what could be done.

A nice feature would be, if the user could turn the “Reply to” header off in the setttings, or if it could be removed completely. But I’m sure there is some sort of a reason for this header to be present.

Greets
Chris

I opend an issue on github but after first reply the seem not interested in solving the problem.
Reply-to-Header is used for years so it’s not caused by new implementation.

Maybe i try it again with a fresh system to make sure i didn’t ripped something up in my first days…

Thank you very much for nice and friendly help, Chris :+1:

I have the same problem using Yahoo. I think CFelix guess is correct. Yahoo doesn’t like the Reply-To header.

Hi,
I’ve solved this problem by replacing the Reply-To headers with the mailadress of my Nextcloud instance.

See here for full instructions.