No apps found for your version NC16

I’ve searched the forum and can’t seem to fix this problem. I didn’t know if anyone else had this problem and might help.

Nextcloud 16
Ubuntu 18 (I’ve also tried NextcloudVM and Nextcloud snap)
nginx (also tried Apache)
PHP 7.3.5-1

Clean install and I don’t have a problem installing. The problem I’m having is when I go to apps from my install all I can see is [No apps found for your version]! It will show current apps I have installed, but when I go to categories it will give me that message.

I’m not sure what logs would help with this.

Does anybody have any advice? Thanks

2 Likes

I have the same issue updated docker NC15 - 16. :frowning:

On my Nextcloud android app i chose “Refresh account”. That partially helped. Now I can find apps when search for them, but updating from notifications doesn’t work.

I cant believe this “No apps found for your version” problem even exists! I am mad for last two days and think of transfer to some other cloud solution…

Just did a refresh install on docker NC16 and seeing the same problem… confirmed internet is available (no changes compare to before). app store also works response. not sure where to look now.

{“file”:"/var/www/html/index.php",“line”:42,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/var/www/html/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",“Line”:185,“CustomMessage”:“Could not connect to appstore”},“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36”,“version”:“16.0.0.9”}

{
“file”: “/var/www/html/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,
“line”: 149,
“function”: “createRejection”,
“class”: “GuzzleHttp\Handler\CurlFactory”,
“type”: “::”,
“args”: [
{
“sink”: {
class”: “GuzzleHttp\Psr7\Stream”
},
“headers”: [
“Date: Thu, 16 May 2019 07:44:28 GMT”,
“Server: nginx/1.10.3 (Ubuntu)”,
“Strict-Transport-Security: max-age=15768000; includeSubDomains; preload”,
“Content-Type: application/json”,
“Content-Length: 2993815”,
“x-content-type-options: nosniff”,
"ETag: “2019-05-16 00:12:21.618946+00:00"”,
“Content-Security-Policy: script-src ‘self’; style-src ‘self’; img-src *; form-action ‘self’; default-src ‘none’; connect-src ‘self’; font-src ‘self’”,
“X-Frame-Options: SAMEORIGIN”,
“Vary: Accept-Language,Cookie”,
“Content-Language: en”,
“Allow: GET, HEAD, OPTIONS”,
“x-xss-protection: 1; mode=block”
],
“response”: {
class”: “GuzzleHttp\Psr7\Response”
},
“request”: {
class”: “GuzzleHttp\Psr7\Request”
},
“options”: {
“verify”: “/var/www/html/data/files_external/rootcerts.crt”,
“timeout”: 10,
“synchronous”: true,
“handler”: {
class”: “GuzzleHttp\HandlerStack”
},
“allow_redirects”: {
“max”: 5,
“protocols”: [
“http”,
“https”
],
“strict”: false,
“referer”: false,
“track_redirects”: false
},
“http_errors”: true,
“decode_content”: true,
“cookies”: false
},
“errno”: 28,
“onHeadersException”: null,
class”: “GuzzleHttp\Handler\EasyHandle”
},
{
“errno”: 28,
“error”: “Operation timed out after 10000 milliseconds with 1343488 out of 2993815 bytes received”,
“url”: “https://apps.nextcloud.com/api/v1/apps.json”,
“content_type”: “application/json”,
“http_code”: 200,
“header_size”: 583,
“request_size”: 112,
“filetime”: -1,
“ssl_verify_result”: 0,
“redirect_count”: 0,
“total_time”: 9.999475,
“namelookup_time”: 0.000053,
“connect_time”: 0.337267,
“pretransfer_time”: 1.1296140000000001,
“size_upload”: 0,
“size_download”: 1343488,
“speed_download”: 134355,
“speed_upload”: 0,
“download_content_length”: 2993815,
“upload_content_length”: -1,
“starttransfer_time”: 1.530382,
“redirect_time”: 0,
“redirect_url”: “”,
“primary_ip”: “88.198.160.138”,
“certinfo”: [],
“primary_port”: 443,
“local_ip”: “10.1.8.14”,
“local_port”: 44832,
“http_version”: 2,
“protocol”: 2,
“ssl_verifyresult”: 0,
“scheme”: “HTTPS”
}
]
}

I also have this problem. No error message in log.

Ubuntu 18.04 running Apache2
PHP 7.2

NC 16.0.1 upgraded from ownCloud and then multiple versions of NC. I had a number of apps disabled in the upgrade steps. I was able to re-enable LDAP at NC 14 (if I recall correctly). Was able to re-enable activity app and others at version 16. But I do not appear to be getting updates on installed apps which I see on another Installation I helped to setup for someone else that is working as expected.

no reverse proxy–reverse proxy seems to have caused this in older NC versions

Show below

Restart apache and reload the page. Sometimes, because of slow internet, the same is shown.

Brilliant. I had the same issue. I changed the timeout value per the GitHub post (changed mine to 50, which works). THANK YOU.

1 Like

Hi Wizlon,
I have the same problem, there is nothing on logs,
Shall I can use your solution, if yes, I don’t know clearly where to config it. can you give more details about it?
Thanks
William

I had the same problems (blank “apps” page and others (f.e. contacts), some were ok).
I compared the upgraded installation with a new installation and hat to disable the app “files_reader”, then all was ok.

Is this the link GitHub post you were referring to?

I also meet the issue, and I just try the followings solution, and it works.

I just change the timeout from 10 to 100, it works for me.
I just wonder why this solution is not phased into the docker version ?

how to set up, would you please show your configuration here for reference?
Thanks a lot

You can check in the link that I post in this article.

However, the solution is as the followings, you need to access the server to find Fetcher.php, and then change timeout value from 10 to 50, 100, or 300.

How to fix

nextcloud/lib/private/App/AppStore/Fetcher/Fetcher.php

@@ -95,7 +95,7 @@
 		}
 
 		$options = [
-			'timeout' => 10,
+			'timeout' => 300,
 		];