No access after config.php change, php error, http error 500, SimpleContainer.php:110 error

Nextcloud version (eg, 12.0.2): 14
Operating system and version (eg, Ubuntu 17.04): ??? hosted
Apache or nginx version (eg, Apache 2.4.25): ??? hosted
PHP version (eg, 7.1): 7.1


I would like to have my own cloud drive but I have no idea how to use Linux.
So I rent a cheep webspace server with apps.
Unfortunately only owncloud was available.
But the provider installed nextcloud for a small extra fee.
Everything worked fine until I tried to add a trusted domain to the config.php using WinSCP as described her (Adding a new trusted domain).

After this change I tried the new and the old link for my nextcloud login.
Nothing happened … no Login … HTTP error 500.

The output of your Nextcloud log in Admin > Logging:

Can't Access

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

this file isn't a log file, it's a config file. Right?

The output of your php_errors.log file:

[01-Oct-2018 19:03:54 UTC] PHP Fatal error:  Uncaught OCP\AppFramework\QueryException: Could not resolve defaultTokenProvider! Class defaultTokenProvider does not exist in /srv/www/XXXX/htdocs/lib/private/AppFramework/Utility/SimpleContainer.php:110

The output of your Apache/nginx/system log in /var/log/____:

I don't know.

The Nextcloud Win Client says php error.

Before changing the config.php I made a backup.
I tried to restore it but this didn’t work either.

I changed php version to 5.3.
Now the login page asked me to use at least php 7.
So nextcloud seems to be there somewhere.
I have no shell access. So I don’t know what to do.

What did go wrong?
I would appreciate any help.