Nitrokey 3 A mini / Nitrokey 3C NFC – U2F not working with NEXTCLOUD

Hello everybody,
i tried to add both adapters from different OS (win10, Linux Ubuntu and Debian) as MFA into my Nextcloud (v26.0.2), but it will not succesfull finalized.

NK3’s is up to date from firmware (1.5.0). All test with nitropy nk3 test --pin “mysecret” are ended with success.

A Test from site will succesful too.

In Nextcloud (v26.0.2) will get the dialog prompt fo inserting the PIN. This action is succesful and i must approve with an tap, but no further is happened.

There occure no error messages.

hi @DE_DE welcome to the forum :handshake:

I have no Nitrokey 3 available but my Nitrokey 2 works fine. I got 2 of them and successfully registered the second one yet with Win 10 and Firefox.

The only issue was my PC first tried using internal TPM (fingerprint/face) and only after cancel this first check I could add the Nitrokey… and the UI is not good - once user confirms key registration by touching the key the dialog to name the key is not very obvious… the user must be very focused to successfully complete the registration.