Nginx reverse proxy real IP

I have the following headers set:

        proxy_set_header        Host                 $host;
        proxy_set_header        X-Real-IP            $remote_addr;
        proxy_set_header        X-Forwarded-For      $proxy_add_x_forwarded_for;
        proxy_set_header        X-Remote-Port        $remote_port;
        proxy_set_header        X-Forwarded-Proto    $scheme;
        proxy_redirect          off;

Now the actual IP shows up in the nginx logs but is not showing up in nextcloud.log. Any ideas?

Current setup:

Primary -> Gateway (reverse proxy/firewall) -> 4 reverse proxies in roundrobin setup.

trusted_proxies

Needed a bit more work but yeah. It’s finally registering the users IP but the create app key option under security still does nothing.

I’ll keep checking into it. Thank you!