Nextcloud's Carddav Server can not be uses as Default Account for an IPhone

Dear Support-Community,

I migrated from an owncloud server to my new nexcloud server. Everything works fine, but I am not able to mark the nextcloud’s carddav server as default account on my IPhone.

I hade a long discussion with apple, but they told me, that it has something to do, that the server has to identify itself in a way, that this is possible. Sorry for this simple description, but more I was not able to figured out of the apple support :innocent:

The account is set-up in the IPhone correctly. I can sync bidirectionally with my IPhone. The only problem is, that new contacts will be automatically created within a different account.

When I connect back to my owncloud instance, the account shows up in the default account list on the IPhone. Therefore I also believe, that it has something to do with the server.

Am I somehow able to change any configuration to enable this feature on my nextcloud server?

Thanks for any answers,
Dirk

Dear Support Community,

is my desciption not understandable?
If you need more information to help me, please send my your questions, I will try to answer them.

Best regards
Dirk

This seems to be more of a problem with how iOS is handling contact cards rather than a NC problem (sorry for throwing the ball back into Apple’s camp). NC has no influence on where a carddav client wants to sync which contacts to neither it can decide which account has been set as the default account at the client’s side. A carddav server just acts as central repository of your addressbook data and nothing more.

There must have been some changes within iOS and how it handles Default Contact Accounts. I have received similar support requests in regards to where iOS is saving contact cards to from other users since iOS 14 has been released.

Have you checked here on how to set the default account for new Contacts on iOS? The linked comment is relatively new (May 2021) and should apply to the actual iOS 14.x.

(As a sidenote: If you are seeking for support you should elaborate on some specifics like NC server version, underlying OS and installation method, iOS version etc. If you keep the support request as vague as you did chances are slim that someone will jump in.
Also there is no obligation to anybody to provide support. If you are demanding suport for your nc installation you should consider to switch from the community edition to the enterprise edition which includes certain support plans. See “Subscription and support”)

Dear Tamsy,
thanks for your answer. I know that this is a community based support and I did not want to be impolite. Sorry, that it could be understood like that.

I am really not sure, on which side the problem is. I had a support session over 1,5h with the Apple support, and they checked all my configurations on my IPhone.
I double checked with the tutorial you supposed and I also did nothing different than that. What is strange, is, that my nextcloud server does not show up in the list of Default Accounts.
The Apple support said, that the server somehow has to identify itself as beeing able to be used as Default Account, but they could also not tell me how it is technically.
To give you more information on my set-up:
I have a raspberry 4.
I installed nextcloud on apache.
Everything seems to work fine. I can upload files, I can sync my calendar and I can change any existing contact on my IPhone and it is synchronised on the server.
Only thing, which does not work, is creating a new contact :frowning:
I run owncloud on the server before, but OCIS seems to come without calendar and contacts app. Therefore I migrated to nextcloud a month ago.
I have now reactivated the old owncloud instance on that server and owncloud can serve a “Default Account”.
That is, why I still believe it has something to do with nextcloud.
But I have a solution now. Running Nextcloud as Fileserver and using Owncloud as Carddav server. A bit too much, but this at least works.
If you have any clue, that would be helpfull, otherwise I give up.

Best regards,
Dirk

I didn’t see an option for setting the default. I don’t have the Mail, Contacts, Calendar on the phone. Since I sync everything to Nextcloud, I just disabled the contact syncing to the apple account.

If you set up the contacts, you could perhaps try and search the logs what the phone is looking for, perhaps the .well-known redirects or something like that.

Apple forum perhaps?

Hey there, after a long search, I ended up using this workaround posted here in the forum by Bernie_O:

I might have found a “real” solution. Disabeling the “Contact Interaction” app did the trick for me. It removes the “recently contacted” address book. Please verify. I’m at NC 22.1.1.

1 Like

Thanks a lot.
That did the trick. I had to delete my account on the IPhone and add it again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.