NextCloudPlus not yet initialized, trying again in a few seconds

OK! Nextcloud not working enymore!!! Dot no what to do!

Am happy to take any help in this regard!


Provide some info on your hardware configuration, which image and installation guide did you follow?
What other steps did you take, before and after the problem occurred.
Run sudo ncp-report and share output via pastebin or similar.

Thank you for your answer!
So! I have a Raspberrypi 4 with 8 GB Ram and a 32 GB Sandisk SD card
(but I have already tried other SD cards, even completely new SD cards) in an Argon One box Power Suply is 3.0 A 5V, i think hardware is ok.
I downloaded the software from: and flashed it with Balena Etcher. I used to do that very often and it always worked. Do not know what happened now it is no longer possible. Believe it is in the images, have no other explanation. Please maybe you can help me.

Sorry i use this install guides:


and this:


  • Unless one is using torrent, one should always check md5sum of downloaded image.
  • The image has been tested and is being used by many. so if md5sum of your file checks,
  • I’d try again with a smaller card, (I use 4 Gb card for OS and NC&NCP and a 1Tb usb drive for NCdata)
  • Also try another program to create the sdcard (in Linux I use dd)
  • for the ncp documentation check
  • if all these fail, you’ll have to go back to basics, which is checking hardware, cables and connections. Replacing 1 by 1 is a way to find a broken cable or charger.

Thank you very much for your answer!

I will try tomorrow, today I have no motivation anymore it cost me too much nerwen, but do not give up. I also have two Nextclouds with one TB usb drives each that work very well. You are right I flashed this with an iMac. Now the problems always arise with Windows.

I will report here how I got on

Did you get that issue worked out? I have been working for hours trying to get through the same issue. 32gb sd, pi 4, 8gb… Also tried a separate 64gb sd card. The pi was purchased from amazon, the canakit.

No, I gave up.
Definitely something happened to the image. 1 month ago I installed 3 times a day without any problems. Now it doesn’t work.

But I have now installed it with Docker starter and see that it worked at first. Try to install like this:

@Jozsef_Albert could you solve the problem?

Yes i tok now the Berrybot image and this work like a charm!

Tok it from hier !


sudo ncp-config
to launch the terminal version of the configuration panel.
install nc-nextcloud
Scrolled down to nc-init and ran it.
you should able to login now .

Hope this help…

Definitely the image is to blame.

The NextcloudPi cannot handle 8 GB memory addressing. Let’s wait until the experts create a customized image.

Hello everyone, I just wanted to share my experience regarding this topic.

I am using ncp on Docker with the ownyourbits/nextcloudpi-armhf image on Pi4 (2GB). Today I decided to update everything and pulled the newest image etc. I then ran into the same problem described here, which I could not fix. Tried a lot of times with fresh folders etc.
What worked though, is a different image (ownyourbits/nextcloudpi). Maybe @nachoparker can pull something from this information (apparently this image was broken once, maybe again?).

PS: I am running my Pi4 on an SSD and power shouldn’t be an issue.

  1. Here is the official, up-to-date 64-bit Lite image for Raspbian.
  2. Instructions for installing 64-bit NextcloudPi Docker

@oerkel47 These should answer all of your questions. Here is a list of resources on the forum, plus

Just let us know if you run into any further problems here or on

Pull the 1.24 image instead. The latest image (1.29.8) isn’t working. See my reply in another thread below.

1 Like

I am having this exact same problem with a fresh new installation of NextCloudPi on an equally fresh new Raspbian installation.
I installed NextCloudPi with the curl method:

curl -sSL | bash

I never get over the activation page.

What the heck do I have to do?


Btw: re-running nc-init doesn’t help …

  • Look at the ncp.log. to find out at which step it gets stuck. (If you have swap already enabled on a partittion, dphys-swapfile install failing, can break init. )

  • Run ncp-report and share via pastebin service if need assistance.

Ok, the situation is as follows:

After a fresh run of nc-init (in ncp-config), I browse to https://raspberry and get this:

I click on “Activate” and get this:


… which never ends.

I do “tail -f /var/log/ncp.log” and see this repeated every few seconds:

[ nc-admin ] (Thu Nov 12 20:10:20 GMT 2020)
Nextcloud is not installed - only a limited number of commands are available

There are no commands defined in the “user” namespace.

I googled this and saw that other people had this error and their config.php was empty. I checked and my config.php was empty, too.
If I do “mysql nextcloud --user=ncadmin” as a superuser, I can access the database, but ther are not tables. So it seems like nc-init didn’t create a database and config file?

Or are the database and config file created by activation?

Please advise…

You should really move this to a new topic rather than tack it onto someone’s report from version 13…

Hmm, did you try reloading the browser? If it doesn’t work, please file a bug report here and follow up at

The solution in this post is LITERALLY just above yours.

I am not using the image. I have a clean Raspberry OS installation and was trying to install via the curl method.