NextcloudPlus Docker stops immediately (RPi)

Here i am again,

i tried to tinker a bit with Docker and the NextcloudPlus image for ARM.

Some information: Fresh Raspbian Jessie Lite installation, docker installed with official blog post from RPi-Foundation and getting the NCP image from @nachoparker s site.

It appears, that the container runs for like 5 seconds and then stops right after a short period. So i tried restarting docker, deleting the Container, running a new one from the same image and so on. Every time with the same outcome.
I don’t want to run the Cloud on Docker on the RPi, but maybe there is something wrong, you aren’t aware of, so maybe i can help you with that?

Just one question off topic. I’m not able to run the ARM-image on a PC/Mac right? Am I able to run the 32bit NCP Docker version on the RPi?

I hope that this thread could be useful,


How do you run your container?
If you omit -d from docker run or docker-compose up you’ll see all messages from the container and might find the source of the problem.

remember to remove the ncdata volume after removing the container for a fresh start